This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Itamar 2 months, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
July 26, 2019 at 4:00 pm

mattH-23

I am trying to add wpml to a dev site we have and translating English to French. This theme does contain ACF which is not seeming to work similarly to how it has before when I have been using WPML. I am unable to make translations of the who field but only the fields within.

If you see this page here you will see the errors appearing: hidden link

July 28, 2019 at 4:14 pm #4295671

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I can see the non-object error at the link that you gave me.

You wrote: "I am unable to make translations of the who field but only the fields within."
I'm sorry, but I don't understand what you mean by that.
Could you please elaborate on this point and tell me where to go on your site see this problem?

On your site, I can see the Advanced Custom Fields: Theme Code Pro plugin, which probably adds ACF functionality to your theme. I suspect that this plugin is not compatible with WPML. But I can also see that this plugin is not updated to its latest version.
Could you please update this plugin and see if the issue persists?

Thanks,
Itamar.

July 29, 2019 at 12:46 pm #4299823

mattH-23

Hi Itamatr,

Sorry about that I think it was a spelling mistake! it should say I am unable to simply translate the WHOLE field but rather the fields within the parent field only. So where I would usually looks at the "Field Groups" page and see a number of english fields and a number of french fields I do not have that, I instead can only see the option of translations within the fields. (screenshot if it helps)

July 29, 2019 at 5:02 pm #4302119

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Can you please confirm that you are following our instructions at the following link on how to work with WPML and the ACF plugin?
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

You need to translate fields groups only if you need the labels of the fields translated in the backend. The fields themselves are translated on the posts and pages that they are assigned to. If you are using repeater fields, then please look at this section to know how to translate repeater fields.
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#setting-the-translation-preference-for-repeater-fields

Please let me know if you have any questions about this issue.

July 30, 2019 at 2:59 pm #4308887

mattH-23

Hi,

I believe I have done this all but the homepage is still not showing any content at this point in time. although looking at the french copy of the page in the backend, content is showing as filled in.

July 31, 2019 at 10:00 am #4313429

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I understand that the instructions at the following link might be confusing.
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#setting-the-translation-preference-for-repeater-fields
The 'Page Builder' fields group that you are using for the homepage is Flexible Content type, which is acting as repeater fields.
Things were not set correctly set on your site.
The documentation says this:

On the post/page editing screen, go to the Multilingual Content Setup box and click Show system fields.

Set the fields that correspond to the repeater field name with an underscore at the beginning to Copy.

All the system fields on the homepage were set to 'Don't translate'. For example, please see the screenshot where I show the link_box system fields. Now I've set all the systems fields to 'Copy,' and they show on the French translation of your site. Please see the attached screenshot.

It seems that the Trying to get property of non-objec error is not related to the ACF fields issue.

Can you please confirm that it is working now?

Thanks,
Itamar.

The topic ‘[Closed] Trying to get property of non-object in error’ is closed to new replies.