Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Yuri 2 years, 2 months ago.

Assigned support staff: Yuri.

Author Posts
August 24, 2017 at 9:46 am #1349817


I've been working on my own plugins for a while now. I use composer to get my dependencies. I know this can be an issue, because WordPress doesn't have an actual dependency manager. So working this way is prone to cause conflicts.

This is also the case with my plugin. It seems you're using an 'old' version of twig, which causes a problem when using my plugin in combination with WPML. This is a controlled environment, so handling conflicts is not a problem. And it's not like my work is so important that YOU have to change your plugin. I'm just wondering why Twig in your plugin hasn't been updated. You're using version 1.33.2, even though twig is already on version 2.4.3.

I fully realise that version 1.33.2 was released in April of this year, and they jumped so many versions in a span of two months. But is there a reason that you can't upgrade Twig? Or it just hasn't happened yet?

August 24, 2017 at 10:14 am #1349857


Hi, we've updated our Twig library version at the beginning of the year since it was a bit outdated but there are no planned updates in the future. One of the main reasons we cannot update Twig to versions over 2.0.0 is that they have dropped the support for PHP 5.x on those versions.

As a rule of thumb we tend to stick with the minimum requirements of WordPress and as of now they still support PHP 5.6 and above.

Let me know if this is what you were looking for.