This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.68 hours from now. Thank you for your understanding.

This topic contains 15 replies, has 3 voices.

Last updated by majidk-3 11 months, 3 weeks ago.

Assigned support staff: Laura.

Author Posts
October 10, 2018 at 11:03 am

majidk-3

Hi.

I use WPML in my site zaffranco.com. I use WooCommerce too.
I set hidden link for Shop page and hidden link for Swedish Shop page. I saw the sidebar in these two pages are different. I don't know what should I do to make them. Also pictures's size of products are different in two URLs.

October 11, 2018 at 2:38 am #2806347

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

When I try to access your site the message "Forbidden" appears. Please note that the "Shop" page works correctly. The problem is only in the backend. I'll attach an image for you to see.

Maybe your host is not allowing external access. Please, could you verify that your host is not allowing external access?

Thank you.

October 11, 2018 at 7:50 am #2807031

majidk-3

Hi Bruno.
I connect to my host provider and explain the problem. When they answer my ticket, I'll try to fix this issue.
I have an Idea. I know my host provider blocks IPs that try to send a lot of requests at a short time to site just for preventing from hack. Sometimes they block wrong IPs. Can you please change your IP and try to connect again?

Thank you.

October 11, 2018 at 11:19 am #2807794

majidk-3

Hi again.
My host provider said that I have to create a password for wp-admin folder and after that they will remove restrictions.
So please create a private message for sending password of the folder to you. thanks.

October 12, 2018 at 2:13 am #2810239

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you. Your next message will be private so you can post the authentication credentials of your server.

Thank you.

October 12, 2018 at 5:57 am
October 12, 2018 at 1:05 pm #2812075

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

Bruno has some days off so I'll take care of your ticket.

I logged into your site to check the sidebar. I see the widgets are in the widget area "WooCommerce shop page", and the widgets are set to be shown in all language.
I tried to set them to display in Swedish, but it didn't work.

Widgets and widget areas are managed by the theme, so we need to search the issue there.
I see the theme Engage isn't in our compatibility list, so this could be the problem.
I'd ask you to do this test:
- backup your site
- disable all plugin except WooCommerce, WPML, and its addons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again

If even in a minimal installation the issue is still present, I'd ask you a copy of the theme to test it further.

As for the photo image issue, I'd suggest you open a new ticket. We try to have only one issue per ticket, so it's easier for others to search the forum. This also allows supporters to be faster and more efficient.

October 13, 2018 at 9:55 pm #2814558

majidk-3

Hi
Thanks for your advises. I'll try them and after that I contact you again as soon as possible.

October 15, 2018 at 7:19 am #2816402

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

sure, I'm waiting for your reply.

October 19, 2018 at 5:35 am #2830570

majidk-3

Hi
Please, my apologies for the delay in reply. I disabled almost all plugins but still Swedish sidebar in WooCommerce still doesn't work. What should I do?

October 19, 2018 at 3:40 pm #2832603

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

could you send me the theme so I can test it in a fresh installation? If I can reproduce the issue I'll escalate the ticket to our compatibility team.

I'll enable a private reply.

October 19, 2018 at 7:38 pm
October 22, 2018 at 10:58 am #2837777

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

can you send me the theme so I can test it?
I'll enable a private reply.

October 25, 2018 at 1:03 pm
October 25, 2018 at 4:56 pm #2850536

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for the theme, but you need to give authorization for download, or I won't be able to use it.