This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Dennis 3 months, 2 weeks ago.

Assigned support staff: Dennis.

Author Posts
June 20, 2019 at 5:34 pm #4062035

andreaB-79

I'm currently using the Ultimate Member Plugin. I need to have the forms translated. However, WPML only gives me the option to translate the form name. Not any of the fields in the form.

I looked on your form compatibility list and Ultimate Member Plugin isn't listed. I also looked at the WPML compatibility section through my WPML login and it doesn't provide me any how to guides on this.

So I have a few questions:
1. Is it possible for me translate my forms from the Ultimate Member Plugin? If so, how?
2. If it's not possible, are you currently working on a fix for this?

My site is hidden link

June 21, 2019 at 9:07 am #4065613

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

Could you please try the following steps?

-go to WPML > Settings > Post Types Translation section.
-set 'Forms (um_form)' to 'Translatable - only show translated items'. Save.

-edit your form at Ultimate Member > Forms
-on edit form screen, on Languages widget, select 'Duplicate'
-click Duplicate

-click Translate Independently.
-on the duplicated form please be sure to select 'Profile form' under the 'Select Form Type' section
-click 'Create'
-take note of the shortcode of the translated form

-edit your Ultimate member (e.g. profile page) at Dashboard > Pages
-translate the ultimate member shortcode using the shortcode of the translated form.
-Update.

Does it help? Please let me know.

Kind regards,
Dennis

July 2, 2019 at 3:16 am #4123411

andreaB-79

Dennis,

Sorry for taking so long to respond. The instructions you gave helped me a lot though I didn't follow it exactly as you listed. However, now I've run into the problem that the Form Translation page isn't saving my translation edits.

I do the following steps:
1. Make a change to the "Translation to: Russian" side.
2. Some times I mark the translation as complete, and sometimes I don't. (I've tried it both ways).
3. Click the "Save" button or click the "Save & Close" button. (I've tried both ways).
4. Check on the live site and confirm the changes didn't go through.
5. Go back to the Form translation page and refresh it.
6. See that the change didn't go through.

I'm not sure how to address this issue. Please let me know how to move forward.

July 2, 2019 at 8:23 am #4124943

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your updates.

Could you please try to translate the form without using the WPML Translation Editor? To do so, please disable the 'Use WPML's Translation Editor' option.

You may need to delete the translation you have previously made using the Translation editor. You can delete forms translation from secondary language by going to Ultimate Member > Forms, then switch the language using the language switcher located at the admin bar, then delete the form translation. Also, delete it from trash. Translate the form again without using the WPML Translation Editor.

Please let me know your results.

Kind regards,
Dennis

The topic ‘[Closed] Ultimate Member Plugin Translations’ is closed to new replies.