This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Bruno 4 years, 11 months ago.

Assigned support staff: Bruno.

Author Posts
November 5, 2014 at 3:06 pm #506256

edwardL-3

Hi,

I have a few issues needing to be resolved.

1. So, I have a site completely in Chinese now, and I am looking to create a Japanese version. To do that, I need to be able to have a different set of translation for the current theme I'm using (MyThemeShop's Truepixel). When I switch to Japanese at the top bar, and change the content, nothing is changed.

I also need to be able to change the text in the sidebar widgets.

2. I am getting this error: When WPML accesses hidden link it gets:
HTTP code: 503 (Service Unavailable)

I am using nginx, so not sure how I can fix this.

Edward

November 5, 2014 at 3:09 pm #506263

edwardL-3

I also noticed, that hidden link is the incorrect URL...if I make it into hidden link it works fine.

November 5, 2014 at 9:31 pm #506477

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

The URL "/jp/?____icl_validate_domain=1" is correct. This is used to verify the translation domain.

Please, as a test, could you disable all non-WPML plugins and see if the problem persists?

Thank you.

November 7, 2014 at 7:13 am #507381

edwardL-3

Yup, all disabled, same issue.

I can reach teepr.com/jp, but I am unable to change the backend settings based on the alternate language.

Everything I change is still universal across the 2 languages (1 default, and the other japanese)

November 7, 2014 at 8:48 pm #507940

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I'll ask for some information so I can verify the problem. The fields for you to insert the credentials will be below its comment field.

Please let me know exactly what steps should I follow to see the problem.

Note: Please make a full backup of your site.

Thank you.

November 10, 2014 at 6:42 pm #509020

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Yes, it can be a false alarm. Sometimes the server response is not as expected by WPML and the error message is displayed. The response expected by WPML is:

<!-- <em><u>hidden link</u></em> -->

If the response received is not similar, the error message will be displayed.

If it is working, even with the error message, it just means that the server's response was not as expected.

Please let me know if you are satisfied with my answer and if I can help you with any other questions you might have.

Thank you.

November 18, 2014 at 12:26 pm #513313

edwardL-3

Sounds good? so I just need to make sure, as long as hidden link works, then we're good, correct?

November 18, 2014 at 12:27 pm #513317

edwardL-3

Also, I am trying to solve a problem here: https://wpml.org/forums/topic/wp-admin-super-slow-after-enabling-wpml-disable-and-immediately-fast-again/ but I am being ignored.

November 18, 2014 at 12:29 pm #513323

edwardL-3

Also Bruno, I'm curious, so in the admin bar, lets just say I change the language to my alternate language, which is JP, am I supposed to be able to access the site's translations in the language?

For example. my theme (Truepixel) has a whole section on string translations, and when I turn WPML into Japanese, am I able to see what that page should be when shown in JP? I'm very confused as to how I can translate my theme into multiple languages.

Edward

November 18, 2014 at 11:39 pm #513821

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

---- so I just need to make sure, as long as hidden link works, then we're good, correct?

Yes. You are correct.

The problem with the other topic will be checked by our developers. George will soon contact you.

When you change the language on the top bar, you'll be able to access content in a second language. For example, you translate posts/pages in Japanese and your default language is English.

When you switch to Japanese, posts/pages will be displayed in Japanese. When you switch to English, English posts/pages will be displayed.

That way you are able to find the post / page you want more easily, and you can do searches of posts in the selected language.

Please let me know if you are satisfied with my answer and if I can help you with any other questions you might have.

Thank you.

November 21, 2014 at 12:18 pm #515638

edwardL-3

Okay, so the button at the top isn't for me to be able to change the translations of the theme.

So, how am I able to change the language of the theme? They're not saved in a PO file, in fact they are all in a sub menu under theme options.

I'm trying to change the language but can't. Thanks!

Also, George has not contacted me regarding the speed of WPML. The speed makes the whole site so slow that I am basically unable to use it, given the huge traffic everyday.

November 21, 2014 at 9:03 pm #515946

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

George sent your topic for our developers check. Soon they will get in touch. I'll send an email to George to answer you.

As the original issue is resolved may I kindly ask you please to open a new ticket for your new question? This will also help other users with similar problems find solutions when searching the forum.

Thank you.