If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by sarah.n 6 years, 7 months ago.

Assigned support staff: sarah.n.

Author Posts
March 27, 2013 at 8:35 am #115224

Pedro

I need to duplicate content for a new language, and I am not able to make it using the translation manager page.

Steps to reproduce this issue:

1. Go to Translation manager Dashboard
2. Click on the "Show all" button
3. Select all the entries (250+)
4. For the target language (EN), click on "Duplicate content".
5. Click on the send jobs button

Expected result:

I should have new content for the new language, duplicated from the main one.

Actual result:

Nothing seems to happen

Thank you.

March 27, 2013 at 9:16 am #115233

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello Pedro,

Can you please confirm that you are using the latest versions of WPML and its active add-ons (if using any)?

You can check the latest released versions under "My Account -> Downloads" on this site. If you need to update, instructions to update can be found here: http://wpml.org/faq/install-wpml/#2 Only backup your database first before you proceed! You can use a plugin for this if you like such as: http://wordpress.org/extend/plugins/wp-db-backup/

If you are using the latest versions of everything, continue with these steps:

1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/,

2. Repeat the action of bulk duplicating content

3. Copy and paste the contents of error_log.txt here for us to see

March 27, 2013 at 11:46 am #115289

Pedro

Hi Sarah,

We are running last WPML build, 2.7.1

Please see attached error_log.txt: http://pastebin.com/f9x5Zs2S

There are some error notices, related to a theme framework, but I don't think they are any relevant.

Do we need to configure anything before duplicating content?

Thank you.

March 27, 2013 at 11:53 am #115291

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hmm... well this is strange. I will send you an email requesting some further information that will help me assist you further.

March 28, 2013 at 8:37 am #115479

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello Pedro,

I have received the details you emailed me. Thank you.

I successfully duplicated "Tres tintas" from your Portfolio items custom post type from the "Translation Management" screen so there is no problem in duplicating individual documents.

I could very well guess that the problem could be related to a server time out or a security limit on how many items can be posted in a request to your server in one go when duplicating all the documents at once. Do I have your permission to attempt that? Is your database backed-up?

April 1, 2013 at 2:26 pm #116153

Pedro

Hi Sarah,

post_max_size is set to 8M. Isn't it enough? If so, we could raise it.

Thank you.

April 1, 2013 at 2:41 pm #116159

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Pedro,

If the current value of post_max_size does not allow for all your documents to be duplicated then I would suggest you experiment with a higher value or bulk duplicate fewer documents at a time.

If checking the post_max_size value does not make a difference then the problem maybe be a different ini setting. Let me know what you find out so I know whether I need to investigate further.

April 1, 2013 at 5:19 pm #116196

Pedro

Sarah,

We've just changed the post_max_size to 32M.

Selecting 5 items seems to do the job, but when selecting all the custom post types (250+) it doesn't work.

Thank you.

April 2, 2013 at 6:27 am #116260

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hey Pedro,

I just tried duplicated 10 documents and that worked fine. The problem may be related to this: http://stackoverflow.com/questions/8710185/new-limit-within-php-1000-fields-per-post-does-someone-know-if-the-number-can#

Can you please check the value for "max_input_vars" and increase that as well?

April 2, 2013 at 7:56 am #116296

Pedro

Exactly. That was the issue.

Raised max_input_vars to a higher value and it works now.

Many thanks for your support.

April 2, 2013 at 8:00 am #116297

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Great! You are welcome. Glad this resolved the issue 🙂