I am unable to open exiting translations in the ATE, and I can therefore not edit the translation.
When I press the pencil, I get the error message “WPML didn’t manage to translate this page”
In the error log I get an ATE server communication error (please see attached image)
It seems to be a problem for both pages and products older than surgent data.
We have recently update all plugins.
I am still able to translate new products automatically
Languages: English (English )Spanish (Español )Italian (Italiano )
Timezone: Europe/Rome (GMT+02:00)
Hello,
That happens sometimes when you migrate sites and you try to open a page that was previously and last translated or edited on another domain.
Try to go to WPML> Translation Dashboard and resend it for translation. You can select the "translate myself" option and then open the translation from WPML > Translation to see if it works.
Once that works, you can open it from any other place moving forward.
You wrote: Try to go to WPML> Translation Dashboard and resend it for translation. You can select the "translate myself" option and then open the translation from WPML > Translation to see if it works.
Reply: That works. That way I am able to open the translation.
We did not never move from another domain, but last December we moved the whole installation to a new server, changed from Apache to Nginx and we changed to the Cloudflare DNS. Can this really be the reason?
I checked the job ID from your screenshot, and I can see that it belongs to an old website entry that is no longer connected to the system.
The translation job was completed in 2025, and it is currently associated with a different site entry in our system. If you remember, this content was translated before we had the site key issues. At that time, the site key was connected multiple times.
We still have all the translation data in our system; only the connection between the jobs and the current site is missing.
Could you please send me the login credentials for the live website? You can send them by email if that is more convenient. I need to check the current website ID. I can make an assumption based on the entries I see here, but I would prefer to confirm it first.
Once I have confirmed the current website ID, I will check with our team if there is a way to reconnect the old translation jobs with the current site so they can be edited again.
As we suspected, the translation jobs belonged to the old site in AMS and were not associated with your current site. Because of this, AMS was rejecting them.
We have now migrated the old jobs to your current site, so you should be able to edit them again.
Could you please check and let me know if everything is working as expected now?
I am still not able to open the editor on older pages and products. When do you expect to have this solved?
Regarding “I have noticed that when I update an older product then I pay for a full translation. Is that also Site/domain mismatch?” I am not able to find a product, so maybe this have been solved.
There was a bug on our side. Our dev team has fixed it, and it is under QA.
I will update you as soon as it is released on the production ATE server.
These two issues are related and depend on each other. So both should be fixed with this one.
If this is urgent and you can not wait any longer, please go ahead and send them for translation again from the Dashboard, and you will see a translation cost in the dashboard before sending. I will add those credits to your account so you can re-translate it without paying.
Please let me know how many credits it is costing if you want to proceed. Otherwise, I can leave feedback to the devs to prioritize this fix.