Skip to content Skip to sidebar

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 14:00 10:00 – 14:00 10:00 – 14:00 10:00 – 14:00 10:00 – 14:00 -
- - - - - - -

Supporter timezone: Asia/Kolkata (GMT+05:30)

Tagged: 

This topic contains 10 replies, has 1 voice.

Last updated by Sumit Singh 6 days, 23 hours ago.

Assisted by: Sumit Singh.

Author Posts
July 31, 2026 at 7:07 am #18186444

peterJ-48

Hi,

Please forward this ticket to Sumit

I am unable to open exiting translations in the ATE, and I can therefore not edit the translation.
When I press the pencil, I get the error message “WPML didn’t manage to translate this page”
In the error log I get an ATE server communication error (please see attached image)

It seems to be a problem for both pages and products older than surgent data.

We have recently update all plugins.

I am still able to translate new products automatically

July 31, 2026 at 10:15 am #18186949

Alejandro
WPML Supporter since 01/2018

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

That happens sometimes when you migrate sites and you try to open a page that was previously and last translated or edited on another domain.

Try to go to WPML> Translation Dashboard and resend it for translation. You can select the "translate myself" option and then open the translation from WPML > Translation to see if it works.

Once that works, you can open it from any other place moving forward.

Can you give it a try and see if that works?

August 3, 2026 at 12:39 pm #18190073

peterJ-48

Hi Alejandro,

You wrote: Try to go to WPML> Translation Dashboard and resend it for translation. You can select the "translate myself" option and then open the translation from WPML > Translation to see if it works.
Reply: That works. That way I am able to open the translation.

We did not never move from another domain, but last December we moved the whole installation to a new server, changed from Apache to Nginx and we changed to the Cloudflare DNS. Can this really be the reason?

Best regards
Peter

August 3, 2026 at 3:18 pm #18190426

Sumit Singh
WPML Supporter since 12/2025

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Peter,

I checked the job ID from your screenshot, and I can see that it belongs to an old website entry that is no longer connected to the system.

The translation job was completed in 2025, and it is currently associated with a different site entry in our system. If you remember, this content was translated before we had the site key issues. At that time, the site key was connected multiple times.

We still have all the translation data in our system; only the connection between the jobs and the current site is missing.

Could you please send me the login credentials for the live website? You can send them by email if that is more convenient. I need to check the current website ID. I can make an assumption based on the entries I see here, but I would prefer to confirm it first.

Once I have confirmed the current website ID, I will check with our team if there is a way to reconnect the old translation jobs with the current site so they can be edited again.

Thanks.

August 3, 2026 at 4:21 pm #18190562

peterJ-48

Hi Sumit

I have send the credentials to your mail.

Please don't take any chances on the production server.

Best regards
Peter

August 6, 2026 at 12:28 pm #18195905

Sumit Singh
Supporter

Hi Peter,

As we suspected, the translation jobs belonged to the old site in AMS and were not associated with your current site. Because of this, AMS was rejecting them.

We have now migrated the old jobs to your current site, so you should be able to edit them again.

Could you please check and let me know if everything is working as expected now?

Thanks.

August 7, 2026 at 5:13 am #18197325

peterJ-48

Hi Sumit,

I tried to open Bulgarian on the About us page, and I also tried to open Bulgarian on an older product SKU: P2D-800-V1. They both failed.

I have attached the error log.

I have noticed that when I update an older product then I pay for a full translation. Is that also Site/domain mismatch?

wpml-edit-translation-1.JPG
WPML-error-log-1.JPG
August 7, 2026 at 2:20 pm #18198512

Sumit Singh
Supporter

Hi Peter,

I think we are still missing something ATE is responding with 503 Service Unavailable now; before, it was 401 Unauthorized.

I have asked the team to check it.

About

I have noticed that when I update an older product then I pay for a full translation. Is that also Site/domain mismatch?

Please let me know the page link so I can check here why you were charged and what we have in the system before.

Thanks

August 20, 2026 at 8:44 am #18216659

peterJ-48

Hi Sumit,

I am still not able to open the editor on older pages and products. When do you expect to have this solved?

Regarding “I have noticed that when I update an older product then I pay for a full translation. Is that also Site/domain mismatch?” I am not able to find a product, so maybe this have been solved.

Best regards
Peter

August 21, 2026 at 1:35 pm #18218936

Sumit Singh
Supporter

Hi Peter,

There was a bug on our side. Our dev team has fixed it, and it is under QA.
I will update you as soon as it is released on the production ATE server.

These two issues are related and depend on each other. So both should be fixed with this one.

If this is urgent and you can not wait any longer, please go ahead and send them for translation again from the Dashboard, and you will see a translation cost in the dashboard before sending. I will add those credits to your account so you can re-translate it without paying.

Please let me know how many credits it is costing if you want to proceed. Otherwise, I can leave feedback to the devs to prioritize this fix.

Thanks

September 7, 2026 at 12:02 pm #18241426

Sumit Singh
Supporter

Hi Peter,

Just an update here: the issue has been fixed and is scheduled to be released with WPML 5.0.

Thanks