If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bobby 3 months ago.

Assigned support staff: Bobby.

Author Posts
August 15, 2019 at 4:54 pm #4402483

mikkelD

I am trying to: Set up translation for a new custom post type

Link to a page where the issue can be seen: on backend

I expected to see: When we create a translation of a custom post type we can normally go back in to edit it later.

Instead, I got: None of the fields we need to edit appear in the editor (but you can see the content on the front end). This also happens when creating a new post in another language--you can create a new post but there are no content fields in the editor. Included screenshots of what the editor looks like on an English page vs a German page.

August 15, 2019 at 8:59 pm #4403341

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

please update your WPML versions to their latest versions found here https://wpml.org/downloads/

also i recommend to review the following add-on plugin for ACF and makes it easier to translate with WPML content provided in fields created with Advanced Custom Fields.

=> https://wpml.org/download/acfml/?section=changelog

Documentation : https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

August 16, 2019 at 7:37 pm #4407987

mikkelD

Thanks Bobby,
I have taken these steps in my local dev environment and it did not resolve the issue.

I would also like to mention that we have about 8-10 other custom post types that were built with ACF that are all translating fine. It just seems to be the one that we have most recently created that has this issue. It seems like there might be a step that was missed when setting up this new post type, but I haven't been able to figure out what it is.

Please let me know if you need any additional information.

August 16, 2019 at 8:35 pm #4408129

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

If possible i would like to take a closer look at the backend to further test this issue

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

The topic ‘[Closed] Unable to edit translation in new custom post type’ is closed to new replies.