Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by roxanneS 2 years, 6 months ago.

Assigned support staff: Andreas W..

Author Posts
December 26, 2018 at 5:46 pm

roxanneS

I am trying to:
Enter my site key under plugins > Commercial tab. The tab shows nothing but "No repositories defined".
Link to a page where the issue can be seen:
hidden link
I expected to see:
A place to enter the key.
Instead, I got:
An empty page.

wpml-registration-error.jpg
December 26, 2018 at 10:04 pm #3035191

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for contacting WPML Support.

I am sorry to hear that you experienced problems with registering WPML. We used to have similar issues in the past which is why I hope that my workaround might solve this issue.

The problem might be related to the repositories.xml which is missing from the directory /vendor/otgs/installer.

Please go to wp-content\plugins\sitepress-multilingual-cms\vendor\otgs\installer using FTP and place the repositories.xml file.

You can download the file here:

repositories.xml file: =>hidden link

Once that is done you need to press "Check for updates" and WPML should work again as usual.

You can find a similar ticket here: https://wpml.org/forums/topic/i-can-not-install-plugins-add new-commercial-no-repositories-defined/

Please let me know if this solved your issue.

Best regards
Andreas

January 3, 2019 at 3:52 pm #3053535

roxanneS

My issue is resolved now. Thank you!