Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Konrad Karpieszuk 2 years, 2 months ago.

Assigned support staff: Konrad Karpieszuk.

Author Posts
September 22, 2017 at 12:26 pm

guidoL-5

I am trying to:

Using the WP ALL Import plugin I am importing translated woocommerce products. Using the following guide:

https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/

Link to a page where the issue can be seen:

hidden link

I expected to see:

Translated products being linked automatically

Instead, I got:

Although products are being imported to their relevent languages but aren't being linked as translations.

I am attaching the xls fiels I am using also the login credentials for my website. You can see and modify the imports I am using in All Imports > Manage Imports. Or you can try importing new products through the files I am attaching. Please delete the previous ones If you are from the new files

If you want FTP Access please provide us with your public key which we can add as SFTP

September 22, 2017 at 12:27 pm #1380345

guidoL-5

Can you please me how can I attach xls files privately here. I see no option to do so.

September 25, 2017 at 5:59 am #1381604

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+01:00)

Hello

I am Konrad and I will try to help you.

Could you give me access to your wp-admin? I am setting next reply to be private.

No need to attach xml files, I see them in your wp-admin panel.

Could you tell me what kind of products did you import? It was simple products or variable or any other?

September 25, 2017 at 6:01 am #1381605

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+01:00)

Additionally: could you instal Duplicator plugin on your site? I will copy your site to debug it locally.

September 25, 2017 at 9:54 am #1381923

guidoL-5

I was importing simple products. I have installed the duplicator plugin

September 25, 2017 at 1:30 pm #1382280

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+01:00)

Hello

did you change anything in your theme? I am not able to log in, i see error:

> Parse error: syntax error, unexpected 'if' (T_IF) in /var/www/hetportaal/www/wp-content/themes/promz/custom/ThemeParent.php on line 240

In case if you stuck, here is a tip how to get into wp-admin with broken theme: log to your site using FTP and rename your theme directory. This will teporary disable a theme (you will have to enable it when fixed problem in theme)

September 25, 2017 at 8:14 pm #1382828

guidoL-5

I am sorry the website is still under development. You can go through now.

September 26, 2017 at 10:24 am #1383364

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+01:00)

OK, I am able to log in now, but I cannot create duplicator packages. I see:

 Fail   [/var/www/hetportaal/www/wp-snapshots]
Fail   [/var/www/hetportaal/www/wp-snapshots/tmp]

If Duplicator does not have enough permissions then you will need to manually create the paths above.   The root WordPress path [/var/www/hetportaal/www/] is currently not writable by PHP.

Could you log in with ftp to your site, create mentioned directories and set chmods to be writable?

September 26, 2017 at 11:57 pm #1384273

guidoL-5

I have given you access and also setup a package from duplicator to download. Please mark these last two messages as private.

September 27, 2017 at 5:38 am #1384374

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+01:00)

OK, thank you. I am downaloding and will try to debug. I will get back to you when find anything.

September 27, 2017 at 6:45 am #1384432

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+01:00)

Hello

Unfortunatelly something is wrong with exported duplicator package.

When I have been installing it, mysql told me there was a lot of errors with missing tables.

After installation it displays site configuration screen so database was not created correctly.

I see this is multisite installation so I believe this is a reason. Could you try to create some new site - not in multisite but separate wordpress installation - and see if importing is not working there? I think it might be conflict between WP All Import or WPML and multisite mode.

September 27, 2017 at 6:14 pm #1385278

guidoL-5

I have made a backup manually for you. It is a zip file with the website and the database. If you could please make the next message private i'll send you the link and you could either use that or extract the missing tables from that..

September 28, 2017 at 5:58 am #1385656

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+01:00)

Hello, I marked your next reply as private.

Also I want to inform you that I am seeing more reports like your in ouir forum, so something is really broken to everyone. I escalated it to our bug tracking system. But having your site dump will be helpful - we will use it to debug and you will be the first who get solution.

September 28, 2017 at 7:24 am
September 28, 2017 at 7:25 am #1385709

guidoL-5

I have sent you the file link. This problem might have occured after the recent WPML update.