This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Oscar Miras 5 months, 1 week ago.

Assigned support staff: Oscar Miras.

Author Posts
May 13, 2019 at 4:47 am #3795141

jalebyM

i'm trying to translate contact form 7 from translation management page. But the page is blocked with a overlay "Learn how to translate media". Also i have another issue, that in translated pages, some of the links are pointing to the english content rather than the translated content. Also my footer is not translating even though the translation is added.

May 13, 2019 at 12:01 pm #3797717

Oscar Miras

Hi,

Welcome to the WPML support team.

Regarding the overlay, it may help to simply click on the links and on the button. Then click elsewhere outside the panel. Eventually, a closing sign will show up at the top right corner of the overlay. This is a well-known interface issue that happens to some clients.

I would like to point out that the theme you are using is not WPML-compatible. It does not mean that you are not going to be able to translate content, but some elements, such as the footer, may require an extra effort to make it work. You can check it here: https://wpml.org/documentation/theme-compatibility

I also would like to inform you that some of the PHP parameters in your WordPress installation are quite low. You need to increase these values in order to meet WPML's requirements.

Could you increase the WordPress memory in your wp-config.php file? The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

Change or modify the following lines:

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Make sure you modify them before the line:

/* That's all, stop editing! Happy blogging. */

There's still one parameter that should be increased because it is very low. It is the max_input_vars value. Currently, it is set to 1000. Try to change it to a higher value such as 10000. To change it, you could do by following one of these options:

  • Add or change the line max_input_vars = 10000 in php.ini
  • Add or change the line php_value max_input_vars 10000 in .htaccess

You can check if your values have been properly updated in WPML > Support.

Related documentation:
https://wpml.org/home/minimum-requirements/

Then, try to translate again the footer and check if it works.

Finally, in order to fix the links translation problem, go to WPML -> Translation Management -> Translate Link Targets, and use the "Scan now and adjust links" button to adjust links in posts and strings so they point to the translated content.

Do not hesitate to contact me in case you need further assistance, I'll be happy to help.

Best wishes,
Oscar.