Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 11 replies, has 2 voices.

Last updated by Fernando 10 months, 1 week ago.

Assigned support staff: Mateus Getulio.

Author Posts
August 6, 2021 at 9:55 pm #9359215

Fernando

I am trying to:

After applying the last updates we are unable to load the site if WPML is activated. It gets into a loop and uses all the ressources.

Link to a page where the issue can be seen:

the whole site is affected sdaqc.org right now I deactivated the extension to make the site work.

I expected to see:

Instead, I got:

the only error I got after deactivating WMPL and adding true to the debug line on wp-config is this one :

Warning: Use of undefined constant ICL_LANGUAGE_CODE - assumed 'ICL_LANGUAGE_CODE' (this will throw an Error in a future version of PHP) in /home/sdaquebec/sdaqc.org/wp-content/themes/liftoff/header.php on line 243

about this line

<hgroup class="header-title">
			<?php
			if(ICL_LANGUAGE_CODE=='en'){ ?>
                <h1 class="site-title"><a href="/en" title="SDAQC" rel="home"><img src="<?php echo get_stylesheet_directory_uri(); ?>/Adventist-Church-Quebec.png"></a></h1>
            <?php } ?>
            <?php
			 if(ICL_LANGUAGE_CODE=='fr'){ ?>
                <h1 class="site-title"><a href="/" title="SDAQC" rel="home"><img src="<?php echo get_stylesheet_directory_uri(); ?>/Eglise-adventiste-Quebec.png"></a></h1>
            <?php } ?>
			</hgroup>

But I guess this is only because WPML is not activated.

Please advise

August 6, 2021 at 10:20 pm #9359359

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

August 9, 2021 at 7:59 pm #9371145

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello there,

Thank you for providing the credentials.

We have just checked your website, but so far, we couldn't replicate the behavior you've reported. After activating WPML, a fatal and 500 errors were triggered indeed, but it disappeared by refreshing the page.

About the loop loading, I installed the Page Load Time extension in order to check it:

hidden link

The page load time difference between the site with WPML enabled X the site with WPML disabled is minimal. The highest I've noticed is two seconds. I also migrated your website to a copy version hosted on our servers, and the results are the same.

Have you managed to solve it in the meantime? If you haven't, could you provide us with more information about how to reproduce the issue? Let us know, please. Thank you!

Kind regards,
Mateus.

August 10, 2021 at 5:28 am #9372655

Fernando

Hello sadly no, the problem is still there.

I've changed the front page to remove the custom code.

I am getting this error now :

Fatal error: Allowed memory size of 478150656 bytes exhausted (tried to allocate 20480 bytes) in /home/sdaquebec/sdaqc.org/wp-includes/wp-db.php on line 2664
Il y a eu une erreur critique sur ce site.

En apprendre plus sur le débogage de WordPress.

Fatal error: Allowed memory size of 478150656 bytes exhausted (tried to allocate 32768 bytes) in /home/sdaquebec/sdaqc.org/wp-content/plugins/sitepress-multilingual-cms/classes/utilities/lock/class-wpml-lock.php on line 1

August 10, 2021 at 5:27 pm #9377313

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Thanks for your reply.

Sorry about this back and forth, but still, we can't reproduce the issue. This is a mandatory step, in order to debug it properly.

Is it happening when WPML is enabled with this custom code you mentioned? If yes, kindly point us to the code location in your website files. Otherwise, please tell us the exact step-by-step in order to see the issue.

Also, we won't reproduce the problem on the live website. Since we have migrated it to a copy version hosted on our servers, we can do it there.

Keep us posted, please. Thanks,
Mateus.

August 10, 2021 at 5:36 pm #9377325

Fernando

Actually I found something, the images uploaded in the site, some of them are not optimized you can find files up to 8mb. Do you think that could contribute to the error? because once I activate WPML (and media translation) the RAM of the server is exceeded and the error 500 is showed.

I am currently optimizing all images.

August 10, 2021 at 5:39 pm #9377337

Fernando

To answer your question, my code is on themes/litoff/front-page.php all archive-xxx.php and single-xxxx.php

THanks

August 10, 2021 at 8:33 pm #9378065

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello there,

So, just to clarify, when you remove the code and enable WPML, does the page load time gets back to normal?

Also, please let us know if the image optimization fixes it. We're looking forward to your reply.

Thanks,
Mateus.

August 11, 2021 at 3:20 pm #9383631

Fernando

Yes the site only loads when WMPL is disabled. The image resolution did not change that issue 🙁

August 11, 2021 at 8:17 pm #9385035

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello there,

Thank you for the updates.

We've just visited your website and could see that although WPML was enabled, the navigation speed was fine. So we tried to check the files you mentioned, but unfortunately, the FTP credentials didn't work. We're receiving an "Error: Critical error: Unable to connect to server" message. At this point, I'd like to ask you to review some information:

#1 First, could you please correct the FTP access? I'm marking your next reply as private, in case you need to enter new data.

#2 As previously said, we must be able to replicate the issue in order to debug it properly and give a possible solution. If it is only happening when these code files are added together with WPML enabled, we need to have access to the files. Please provide us with directions to them. If they are currently removed from the website files due to the performance issue, you can upload them in a tool like Google Drive, or Dropbox, and then share the link with us in your next private reply.

#3 At last, can you please get in touch with your hosting provider and ask them if everything is working well on the server-side? Also, we'll need to check the HTTP server error logs, considering this can be a server error. While we continue to investigate this, please ask them to provide you with the HTTP error logs for the last 2 or 3 days. Make sure to ask for the correct server logs, which are the HTTP error logs, and not the server access logs.

This is probably going to be a huge text, so instead of pasting it in the ticket as plain text, please add to a text snippet like https://pastebin.com/ and send us the link where we can see those logs.

Alternatively, please upload it to the server and tell us where it’s located so we can go ahead and download the logs. Please review this with them and let us know the results of the investigation.

Kind regards,
Mateus.

August 12, 2021 at 8:34 pm #9391859

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello there,

Thank you for providing the server logs.

Based on our tests and diagnosis, we've concluded that the issue is not caused by WPML. We tried to replicate it enabling our plugin on the website, but the slow performance persisted even though we disabled it back.

We also made a copy of your site on a different server, and there the issue doesn’t happen, so we can’t debug it further in there. These tests gave us an indication that this issue could be server-related.

With that said, I'd like to ask you to get in touch with your hosting provider and address it with them. This is necessary because they have more information about the settings that are causing the issue and will be able to provide you with the needed fix for the performance improvement.

Thanks for your understanding,
Mateus.

August 19, 2021 at 12:49 am #9421715

Fernando

My issue is resolved now. The Hosting provider added more memory to the VPS and that resolved the issue. Thank you!