This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 3 voices.

Last updated by Lauren 1 year ago.

Assigned support staff: Lauren.

Author Posts
October 2, 2018 at 6:26 am #2780440

issacN

I wanted to have a different logo on different language. However I couldn't able to locate the logo ID/URL in String Translations. Would you like to have a look of it?

October 3, 2018 at 12:34 am #2783025

Ricardo Alday

Hi,

Please increase your WP memory as WPML requires at least 120MB to work. Also, increase the max_input_vars value in your PHP settings from 1000 to 5000 and then try to add the string from WPML -> String Translation -> "Translate texts from admin screens" again. If successful, the string will show at the beginning of the list in WPML -> String Translation.

Hope that helps,
Ricardo

October 3, 2018 at 5:07 am #2783505

issacN

Hello,

I have updated the max_input_vars value, still isn't able to locate the log ID or URL. Besides, I wasn't able to locate "Translate texts from admin screens", here's the screen shot: hidden link

October 3, 2018 at 2:57 pm #2784952

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi Issac, Ricardo is off for a few days so I am stepping in to help out. I hope that is okay. I have shared a screenshot of where the link for admin texts is. Also, have you increased the WP Memory as Ricardo mentioned above?

I see that you have Media Translation installed. Have you tried translating the logo image? Go to WPML -> Media Translation and upload the logo image that you would like for your secondary language.

Does this resolve the issue for you?

October 5, 2018 at 2:42 am #2789416

issacN

Hello,

I wasn't able to resolve the issue, would you like to log in to site?

October 5, 2018 at 1:31 pm #2790923

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

October 8, 2018 at 2:51 pm #2796485

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending access. I can see that the logo does not have an image uploaded as a translation. Please try that first by going to WPML -> Media Translation. On the last page, you can see the "+" icon next to your logo. Please click that and upload the translated logo and let me know if this resolves the issue.

October 9, 2018 at 3:40 am #2798156

issacN

Hello,

Thank you logging in. I am afraid the screenshots that you've shared earlier isn't the logo that I have intended to change accordingly to the language switch. I have attached the screenshots for the logos that I wanted them to be translated. Kindly assist on this

October 9, 2018 at 2:03 pm #2800341

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks so much for clarifying. I found that your theme requires the image ID to be translated in String Translation. The custom logo ID is stored in the admin texts. So I added this code to WPML -> Settings -> Custom XML Configuration:

<wpml-config>
    <admin-texts>
        <key name="theme_mods_oceanwp">
            <key name="osh_logo"/>>
            <key name="custom_logo"/></key>
    </admin-texts>
</wpml-config>

Now you can see that the correct image is showing for each language. Please let me know if you need any further assistance and I will be happy to help.