Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 15 replies, has 2 voices.

Last updated by jean-paulS 8 months, 1 week ago.

Assigned support staff: Yvette.

Author Posts
April 3, 2019 at 12:07 pm

jean-paulS

Hi,
I have a bilingual website under development (EN-NL) with a subdomain for the Dutch(NL) pages. (The site is "alive" but hid for search bots.)
 
It is not possible to post a comment under a Dutch/NL post. The page renews after posting the comment, but all the content is gone, included name and email. On the English posts, it works fine
I switched from a subdomain to “Different languages in directories” for testing purpose, and then it works. So the problem lies there somewhere. And strange enough, when I return to the subdomain, the latest comment I made for testing disappears. It is still in the dashboard “Comments,” but not under the Post anymore.

April 3, 2019 at 3:03 pm #3527749

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

I just tested this in my local test system setup with domains-per-language and was unable to reprdouce the problem.

I also connected to your site and confirmed that the problem exists as you described.

Could you please confirm that this same problem happens if you temporarily change your active theme to Twenty Seventeen and also temporarily deactivate you non-WPML plugins?
(In this case, your setup will be the same as my local testsite and we can then discard server-related issues).

As a preliminary diagnosis, I can see that there is an error reported when attempting to post the comment in the NL language of the type:
"Access to XMLHttpRequest at 'hidden link' from origin 'hidden link' has been blocked by CORS policy: Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource..."

So it seems a problem of cross-domain permissions but it is not clear if this is being caused by our plugins, another plugin or by your theme.

I will be investigating if there are any reported errors of this type while you do the diagnostic tests as requested.
Thanks

April 3, 2019 at 4:49 pm #3528931

jean-paulS

Hello Yvette,
I changed the theme to the default one (twenty nineteen in my case) and deactivated all the plugins except for the WPML ones, and I could post a comment (and approve it). Before contacting you, I already asked DIVI support to take a look at it, and they say it' s not the theme that is the cause. So it should be one of the other plugins. I suppose I activate them now one by one and post a comment over and over again?

April 3, 2019 at 5:09 pm #3529199

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Yes. That is what you should do until you find which plugin is causing the issue.

April 3, 2019 at 6:19 pm #3529681

jean-paulS

Hello Yvette, once again,
I found the guilty one. It was WP Bruiser, "An extremely powerful anti-spam plugin..." A little too powerful in my opinion. Will see what I will do about it. Thanks for the help and kind regards.

April 3, 2019 at 6:39 pm #3529833

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Congrats! Ok - should we keep this ticket open or close it?
Maybe if you decide that you need this, we can open a compatibliity ticket for further investigation. IN this case, let me know and I will create a sandbox site where you can load up the plugin and we can recreate the problem to then send it on to our compatibility team.

I`ll leave it up to you.
Kind regards

April 3, 2019 at 7:29 pm #3530177

jean-paulS

Well, if it should be possible to keep using the WPBruiser plugin, I won't say no. So you can open a compatibility ticket.

April 4, 2019 at 6:38 am #3532349

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Ok.

I have prepared the following sandbox site wiht pre-loaded/pre-configured WPML plugins.
Please now upload the Bruiser plugin and configure an example that illustrate the incompatibility we have discovered.

hidden link

Once this is done, I can then send it to the comaptibility team.
Thanks

April 4, 2019 at 7:16 am #3532777

jean-paulS

I see that when I disable “Protect Comments Form” in the WPBruiser “WordPress” settings, I can post a comment on the Dutch posts. The protection is about the maximum number of characters for comment field, name, email and website field. This is of course very handy for preventing spam and too long comments, and I would like to keep it enabled if possible. So the problem lies there.

April 4, 2019 at 7:19 am #3532797

jean-paulS

Didn't saw your latest reply. Will upload the plugin and the example.

April 4, 2019 at 7:46 am #3532885

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Great - thank you!

April 4, 2019 at 8:21 am #3533111

jean-paulS

On the sandbox site, I can't submit a comment, not even on the English posts when WPBruiser is enabled. I have to deactivate it completely to post a comment. Under "Reports" in the WPBruiser "settings", you can see the Blocking reasons and under "View Blocked Content" what I did (in the "content" of the comment) and on which part of the site (Spanish or English). The comments I could write on both parts are with WPBruiser disabled. I suppose you send my previous remarks to the compatibility team as well?

April 5, 2019 at 10:19 am #3543019

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

I was able to post a comment in the default language but it needed moderation.

In any case, the compatibilty team will do thorough testing - no worries.
The ticket is now escalated.

April 8, 2019 at 6:57 pm #3560887

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

I have been given a "fix" that I´ve tested on the sandbox site and it seems to work. Please go ahead and test there.

The fix is the following.
Replace line 65 in file: wp-content/plugins/goodbye-captcha/engine/modules/GdbcBasePublicModule.php

with the following line:

$clientUrl = esc_attr(esc_url(site_url('/', MchGdbcWpUtils::isSslRequest() ? 'https' : 'http') . '?gdbc-client=' . GoodByeCaptcha::PLUGIN_VERSION . '-'));

This is essentially the same line but with the "home_url" being replaced with "site_url".

If you are satisfied that it fixes your situation, please go ahead and implement the fix on your own site. You should also notify the plugin author about the fix and be aware that if you upgrade the plugin you may overwrite the fix. The ideal situation is that the plugin author will include the fix in the next plugin release.

Kind regards

April 10, 2019 at 8:07 am #3573299

jean-paulS

Hello Yvette,
Thanks for the “fix.” Strange enough, without changing line 65, I can post comments on both parts of my site now, even with “Protect Comments Form” enabled in WPBruiser (see my note of April 4 at 7:16 AM). Anyway, I will notify the plugin author about the issue.
I have another issue with GDPR Cookie Notice and WPML but will start a new topic for it.
Thanks for the excellent support and kind regards.