Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: "Sorry, you are not allowed to preview drafts." Solution: https://wpml.org/forums/topic/bug-impossible-to-preview-posts-written-in-default-language-on-other-domain/#post-1548101

Solution: Disabling "Auto sign-in and sign-out users from all domains" from WPML -> Languages resolved the issue.

I've checked your site and this option seems to be active.

There is a possible explanation behind this: https://wpml.org/forums/topic/cant-preview-changes-on-second-domain/#post-3346141

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by jean-paulS 6 months, 3 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
May 16, 2019 at 9:15 am

jean-paulS

I am trying to:
Preview my translated posts (with a subdomain)
Link to a page where the issue can be seen:
hidden link
I expected to see:
The preview of my page
Instead, I got:
"Sorry, you are not allowed to preview drafts."

May 16, 2019 at 9:35 am #3823911

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Thank you for contacting WPML support!

Can you try this?
https://wpml.org/forums/topic/bug-impossible-to-preview-posts-written-in-default-language-on-other-domain/#post-1548101

Solution: Disabling "Auto sign-in and sign-out users from all domains" from WPML -> Languages resolved the issue.

I've checked your site and this option seems to be active.

There is a possible explanation behind this:
https://wpml.org/forums/topic/cant-preview-changes-on-second-domain/#post-3346141

Regards,
Bruno Kos

May 16, 2019 at 12:00 pm #3825641

jean-paulS

Hi Bruno,
Thanks for this simple but effective solution. I don't see any problem when switching languages, so I can leave "Auto sign-in and sign-out users from all domains" disabled, so everything works fine now.
Have a fine day,
Jean-Paul

May 16, 2019 at 12:01 pm #3825647

jean-paulS

My issue is resolved now. Thank you!