This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Itamar 1 year, 5 months ago.

Assigned support staff: Itamar.

Author Posts
May 7, 2018 at 1:04 pm #2012443

sonetel

I am trying to: Save translation

Link to a page where the issue can be seen:

I expected to see: Saved translation

Instead, I got: infinite loading and 403 in chrome dev tools (screenshots)

May 8, 2018 at 10:25 am #2028114

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Thank you for contacting the WPML support forum.

Is everything updated on your site?
Do WPML and WordPress are updated to their latest version?

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations.
We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

Thanks,
Itamar.

May 8, 2018 at 11:08 am #2028832

sonetel

Yes, WordPress is up to date (4.9.5) and the WPML plugins too:
- WPML Multilingual CMS (3.9.4)
- WMPL String Translation (2.7.3)
- WPML Translation Managment (2.5.2)

May 8, 2018 at 7:15 pm #2039097

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Thanks for sharing this information with me.

By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.3 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform those procedures and see if it help?

Thanks,
Itamar.

May 9, 2018 at 7:21 am #2044476

sonetel

Hi,

I increased memory limits so minimum requirements are met. Issue still occurs.

What is the next step?

May 9, 2018 at 6:30 pm #2059804

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for increasing the WP Memory Limit.

Please try to see if it is still happening in a minimum environment.
I suspect that there is a collision with the theme of another plugin.
If possible get your site into a minimum environment.
Minimum environment means switching to a default WordPress theme like Twentyseventeen and no plugins activated but WPML.
Is it possible for you to try it?
You will need first to check if the problem persists when just the theme is switched to Twentyseventeen (for example).
If it persists, then turn off all plugins but the WPML (leave WPML and its components active).
Then please check if the problem persists.
If it does not persists so start by activating the plugins one by one and check when the problem comes back. Then report to me which was the culprit plugin.


**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Thanks,
Itamar.

May 14, 2018 at 12:26 pm #2119333

sonetel

Hello,

I changed theme to twenty fifteen and I deactivated all plugins except WMPL. The issue still occurs.

May 15, 2018 at 12:10 pm #2138364

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for trying my suggestions.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.
You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.
Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.
** IMPORTANT **
- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link
 
Thanks,
Itamar.

The topic ‘[Closed] Unable to save translation (403)’ is closed to new replies.