If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 3 voices.

Last updated by alonE 3 months, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
July 15, 2019 at 11:14 am

alonE

I am trying to:
1. Change the default language on my client's website to Hebrew (See attachment 1.png)
2. Some translations on the website are also display in English where I definitely translated them to Hebrew (See attachment 2.png)

Link to a page where the issue can be seen:
hidden link

I expected to see:
1. The hebrew translations: ("העגלה ריקה" & "בחזרה לחנות")
2. I expect the admin pages to be translated to Hebrew as defined in the top bar

Instead, I got:
1. The original English strings ("Your cart is currently empty." & "Return to shop"
2. Almost all of the admin pages, including the menus are displayed in English

July 15, 2019 at 5:20 pm #4213783

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Sadly, I am not able to access your WordPress login page. Could you please verify why I am receiving a 403 error?

Further, after changing the WPML default language did you go to Settings -> Permalinks and click the save button? The procedure will avoid 403 errors on your pages.

In order to diplay the admin texts in Hebrew please go to your WordPress Profile and verify if the site language is set to default. Further, you can check the option "admin language as editing language" to dynamically change the WordPress administration language, according to the content's language.

In case of the WooCommerce cart, do I understand right, that those strings been translated correctly and now apear in reverse order?

There might be various reasons for that. Could you please go to WPML -> Theme and Plugin Localization and verify if the option " Assume that the original language of all strings is English" is enabled? You can find it at the top section of the page.

Further, did you try to locate the string on String Translation? It might be that the string is assigned to the wrong default language. Trz to locate the strings by using the text search field. Then verify to which language (flag) they are assigned. You can here mark strings and change their default language at the bottom the the strings module.

Also, make sure that all plugins and the used theme is up-to-date. Also go to WooCommerce -> Status and check for notification in regards to outdated WooCommerce template files, which are bz default saved in the theme folder. You will here find further instructions about how to update those template files.

I hope this solved the issue.

Kind regards
Andreas

July 18, 2019 at 5:52 am #4235121

alonE

Thanks, we will check this and let you know

July 18, 2019 at 12:25 pm #4238677

alonE

Hey, Can you please let us know your IP address? We couldn't identify any reason for the 403 error. My client did try all your suggestions but none of them works unfortunately (We tried it on 2 different admin accounts).
We also have the FTP details if you would like to check the filesystem, but I don't know how to send the password securely.

July 18, 2019 at 4:45 pm #4241173

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

My public IP address is 179.6.216.39

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

July 18, 2019 at 5:51 pm
July 18, 2019 at 8:01 pm #4242131

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you very much for your message.

Please leave me a short notification once you received the confirmation from your hosting provider and I will have a closer look into the issue.

I would further suggest you to test if the site behaves the same way if you disable any additional plugin but WooCommerce and WPML and its add-ons.

If the issue disappears start reactivating the inactive plugins in small groups or one by one. This way we will be able to determine which components are having conflicts.

Also try to inspect what happens if you switch to a default theme like Twenty Seventeen.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Let me know about the outcome.

Kind regards
Andreas

July 21, 2019 at 6:32 am #4251387

alonE

Hey,

We whitelist your IP so I think that the 403 issue should be resolved (If not, I will be happy if you can send me a screenshot of the error you're getting and i'll send it to the hosting provider for investigation). Can you please try araig?
My client tried to deactivate some plugins but it didn't help to solve the translation issues.

Thanks

July 24, 2019 at 3:43 pm #4276193

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

Andreas is not available today so I'll continue to handle this ticket. I hope that it is alright with you.

I was able to access your site. I form Israel so maybe this helped not getting the issue that Andreas had.

I've fixed this issue by doing the following.

1. I went to WPML -> Theme and plugins localization.

2. And under כיצד לתרגם מחרוזות וערכות עיצוב בתוספים?
I selected
תרגם ערכות עיצוב ותוספים באמצעות 'תרגום המחרוזות' של WPML וטען תמיד קובצי .mo כגיבוי
And pressed the 'Save' button.

And now it is working. Please see the attached screenshots.

The option that was selected was:
רגם ערכות עיצוב ותוספים רק באמצעות 'תרגום המחרוזות' של WPML (אל תטען קובצי .mo)
And even with this option, the strings from .mo files should show.
My suspicion is that changing the default language caused this issue.

Please let me know if you want me to continue to investigate why it is not working with the first option.

Regards,
Itamar.

July 30, 2019 at 10:08 am #4306771

alonE

My issue is resolved now. Thank you! 🙂