This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.60 hours from now. Thank you for your understanding.

This topic contains 9 replies, has 2 voices.

Last updated by Bruno 2 months, 2 weeks ago.

Assigned support staff: Bruno.

Author Posts
July 29, 2019 at 7:11 pm #4303247

richardS-37

I am trying to: translate the text of a button to another language

Link to a page where the issue can be seen:hidden link

I expected to see: the button text change to Contact us

Instead, I got: the original (Dutch) text, Maak een afspraak

July 29, 2019 at 7:13 pm #4303249

richardS-37

I followed the article on hidden link and I am able to see the option, check it and apply it. But I'm then unable to find it in the string translation table

July 29, 2019 at 8:43 pm #4303483

richardS-37

Sorry, changed the URL's, but the button can be seen on any page which is at hidden link

July 29, 2019 at 8:49 pm #4303489

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. I would be very happy to help you but I didn't fully understand what is the issue. What button are you talking about? Is that the top button?

Can you please elaborate a little more so I can better understand? Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

Thank you.

July 30, 2019 at 8:34 am #4305727

richardS-37

Hi,

sorry for the late response but the issue is exactly with the button you're pointing to.
It is part of my header and when I switch to English I would that the button also gets translated. I've read the and followed the step in the article on hidden link but I can't find the right string in the string translation table.

So I have done step 1 to 3 of the article and in step 4 I cannot find the string containing the Maak afspraak text.

In the attached screenshot you'll see that the header is in English now, but the button text is still Dutch.

If you'd like we can setup a webex or zoom conference call so that I can show you what the issue is.

Regards,
Richard

July 31, 2019 at 12:37 am #4310815

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. This may be related to some change in the theme. Where do you set this button? For example, if you want to change this label in the default language, what steps should you take?

I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

August 2, 2019 at 7:45 pm #4332385

richardS-37

Hi,

could you please help?
Thanks,
Richard

August 2, 2019 at 8:46 pm #4332543

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

My sincere apologies for the delay. I fixed your site and now it is working properly. I followed the steps below:

- Click on the WPML > Settings > Custom XML Configuration
- Insert these lines:

<wpml-config>
    <admin-texts>
        <key name="astra-settings">
            <key name="header-main-rt-section-button-text" /></key>
    </admin-texts>
</wpml-config>

- Click on the Save button
- Click on the WPML > String Translation
- Change the String to the Dutch
- Translate the String

Please, could you check if the button is being displayed translated correctly?

Thank you.

August 5, 2019 at 9:22 am #4339263

richardS-37

It's working now, thank you very much for your help!
Regards,
Richard

August 5, 2019 at 7:11 pm #4342697

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Richard,

Glad to hear that it now works. Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.