This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by gerbenv-3 11 months, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
October 15, 2018 at 9:57 am

gerbenv-3

Hi,

I am trying to:
Translate certain strings (Title and description) for payment methods in WooCommerce. e.g. PayPal and BACS

Link to a page where the issue can be seen:
hidden link

You first need to put items in the cart

I expected to see:
*

Instead, I got:
*

Kind regards,

October 16, 2018 at 6:15 pm #2822044

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

You can translate the title and description for payment methods in Strings Translation section.
You can even get to Strings Translation and directly translate the payment method string if press on the translation link in the payment method screen. Please see the attached screenshots payment-screen.jpg and payment-string.jpg.

But when I go to your site now to the checkout page, I see that the PayPal and BACK strings are translated. Please see the attached screenshot payment-trans.jpg.
Have you fixed this problem already?

Regards,
Itamar.

October 17, 2018 at 7:57 am #2823617

gerbenv-3

Hi Itamar,

Thanks for the help.
What adjustment have you made to make these strings visible?
I'm now able to translate most of the strings however, i'm unable to change the language (besides English) of the string (title:paypal and title:BACS) It seems the string is missing.
How can i resolve this?

Kind regards,

Sjoerd

October 17, 2018 at 7:08 pm #2825713

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Sjoerd.

You ask: "What adjustment have you made to make these strings visible?"
On your site, I didn't change a thing.

You can change the language of the string to Dutch by pressing the language option below the field and selecting Dutch. Then press the 'translations' link, and you will find it in the Strings Translation section. Please see the attached screenshot change-string-lang.jpg

Please let me know if this information is helping you to solve the issue.

Regards,
Itamar.

October 18, 2018 at 5:14 am #2826632

gerbenv-3

Hi Itamar,

I've tried that but it wo'nt change from English to any language, it won't save. When i click the translations link next to it, WPML can't find the string. When I update the strings via localisationn of theme and plug-ins, it still does not show. Am i forgetting something? Can I create a string when it is missing?

Kind regards,

Sjoerd

October 18, 2018 at 9:01 pm #2829642

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi Sjoerd.

I can see this issue on your site.
It is indeed strange that it is only happening with the PayPal and BACS titles.
I'm consulting our second tier supporters about this issue and I'll get back to you here.

Thanks,
Itamar.

October 21, 2018 at 9:27 am #2835368

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Sjoerd.

It seems that I would need to debug this issue further on my local server.
For this, I need a copy of your site.
Do you allow me to install the DUplicator plugin (https://wordpress.org/plugins/duplicator/) on your site and make a copy of it?
If you prefer to do it on your own, you can provide me with a snapshot of your website following these directions:
If you already know how Duplicator works, please skip the following steps and just send me the installer file and the zipped package you downloaded.
Duplicator instructions
- From WordPress plugin page, look for “Duplicator” and install it.
- Once installed, you get a new item in the main menu “Duplicator.”
- Chose “Packages.”
- Click on the first button you find in the toolbar on the right (“Create Package”)
- Give it a name or leave it as is
- Click on “Create Package Set.”
- Wait until the package is ready
- Click on “Installer”, then on “Package”: the first one is just a PHP script, the second one is a zip file containing everything you need
- Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big). I'm enabling private message for the next reply.

Thanks,
Itamar.

October 22, 2018 at 6:27 am #2836884

gerbenv-3

Hi Itamar,

No problem. Go ahead.

Kind regards,

Sjoerd

October 23, 2018 at 3:57 pm #2843388

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Sjoerd.

I've made a copy of your site and checked things on my local server. I've found a way to fix this issue. In the WooCommerce payment option's screen, I've removed the 'Paypal (Internationaal)' and 'OverBoeking, bank/giro betalingen (Internationaal)' strings and switched the language of the string to Dutch and saved the changes. Then I've added the string again and saved the option again. And now things work, and you can translate those options names in the Strings Translation section.
Please see the attached screenshots paypal-ok.jpg and paypal-in-st.jpg

Can you please confirm that it is solved?

Thanks,
Itamar.

October 24, 2018 at 1:53 pm #2846701

gerbenv-3

My issue is resolved now. Thank you!