This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 21 replies, has 2 voices.

Last updated by Carlos Rojas 4 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 26, 2019 at 10:06 pm #3892497

curtisP-2

I am trying to:

Translate content in a page built using Elementor.

Link to a page where the issue can be seen:

My home page: hidden link

I expected to see:

I expected to see it work as easily as it did in this video...
hidden link

Instead, I got:

hidden link

May 27, 2019 at 9:10 am #3895047

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML and Elementor.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

May 27, 2019 at 12:45 pm #3897229

curtisP-2

Please see this video that demonstrates my results after taking the steps you suggested...

hidden link

Spoiler alert: It still doesn't work.

May 27, 2019 at 12:47 pm #3897259

curtisP-2

Just after my last reply, I received a system email from WP. I've taken a screenshot of it. Hope it helps.

May 27, 2019 at 1:34 pm #3897703

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

I kindly ask you to follow this steps:
- Create a full backup of the site./strong>
- Go to WPML -> Support -> Troubleshooting link -> Apply the troubleshooting options pointed out in the attached image.

Does the issue persists?

Regards,
Carlos

May 27, 2019 at 1:54 pm #3897995

curtisP-2

Hi Carlos,

I did as suggested in the image and no change. I still get the error. I can provide my site admin login info if it will help.

Curtis

May 27, 2019 at 6:58 pm #3900365

curtisP-2

Hi, is there a chance I can get some help before the end of today?

May 27, 2019 at 8:02 pm #3900687

curtisP-2

Hi, I'd like to add that I can no longer access the Translation Basket... (see attached image)

May 28, 2019 at 8:04 am #3903765

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

May 28, 2019 at 7:24 pm #3909721

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

Before we continue I need to ask you to update all outdated plugins to their latest version. Outdated functionalities can cause conflicts in the code.

Note: Please confirm you have a full backup of the site so I can run some test and restore the site if necessary.

Regards,
Carlos

May 28, 2019 at 9:48 pm #3910409

curtisP-2

Hi Carlos, you're good to go. All updates are done and I've backed up my site.

May 29, 2019 at 9:32 am #3913913

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you for your update.

I ran some tests in the site in a minimal environment (only WPML and Elementor plugins activated) and I get a 500 error when trying to save any change to the frontpage using elementor.

Please activate the debug mode in the site by following this steps: https://codex.wordpress.org/Debugging_in_WordPress and let me know if there is any error message in the debug.log file withing wp-content folder.

I also recommend you to contact your hosting providers and let them know about this errors, maybe they can give you more information about this problem.

Regards,
Carlos

May 29, 2019 at 11:23 am #3914813

curtisP-2

Here is what my hosting company has provided from the debug log...

[Wed May 29 04:27:41.511914 2019] [lsapi:error] [pid 12059:tid 140081613600512] [client 93.176.149.111:0] [host <em><u>hidden link</u></em>; Backend fatal error: PHP Fatal error: Uncaught TypeError: Argument 1 passed to WPML_Elementor_Register_Strings::register_strings_for_modules() must be of the type array, null given, called in /home/imcurtis/domains/mercadoartista.com/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/st/compatibility/class-wpml-page-builders-register-strings.php on line 57 and defined in /home/imcurtis/domains/mercadoartista.com/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders-elementor/src/class-wpml-elementor-register-strings.php:12\nStack trace:\n#0 /home/imcurtis/domains/mercadoartista.com/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/st/compatibility/class-wpml-page-builders-register-strings.php(57): WPML_Elementor_Register_Strings->register_strings_for_modules(NULL, Array)\n#1 /home/imcurtis/domains/mercadoartista.com/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/st/class-page-builder-integration.php(61): W in /home/imcurtis/domains/mercadoartista.com/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders-elementor/src/class-wpml-elementor-register-strings.php on line 12\n, referer: <em><u>hidden link</u></em>
May 29, 2019 at 11:32 am #3914903

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

If you create a new page with Elementor and save it, does the issue persists?

Regards,
Carlos

May 29, 2019 at 12:11 pm #3915287

curtisP-2

Hi, I was able to create a new page using Elementor and use the translation function!!! I will rebuild my home page.

Thank you.