This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by mohammedJ-10 1 month, 2 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
August 29, 2019 at 10:16 am #4479853

mohammedJ-10

How to display on the post non translated content when content is not translated. as not all the content can be translated,

secondly, there is some text that is review of our customer (taken from trust pilot)
I am unable to translate that,
whenever I am trying to translate the content, it throws the below error,

[
Translation not saved
The original sentence includes formatting markers. However, not all markers are applied to the translation
]

August 29, 2019 at 11:36 am #4480547

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello there,

To display the untranslated post,
- Goto WPML > Settings > Post type translation
- For the post type "post" select the option "Translatable - use translation if available or fallback to default language" and click apply.

Documentation : https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

For your second issue this is expected behavior, Please check the solution already posted by our supporter https://wpml.org/forums/topic/in-translation/#post-2789856

I hope this helps you better

Kind regards
Raja

August 29, 2019 at 2:22 pm #4481731

mohammedJ-10

Hello Raja,

Thank you for your feedback on the above,
now in our case WPML we are using it in our word press website, the below mentioned solution I couldn't find under wordpress (WPML) app,

regarding the second issue, I still couldn't fix the error within WordPress site, is there any thread that shows the solution on a wordpress site?

Many thanks.

August 30, 2019 at 4:57 am #4484735

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Please share temporary access to your site let me look into the first case. I have enabled private fields for you to securely share the details.

For your second issue, the thread I shared has a solution to resolve the conflict, Share me the URL where I can see the issue let me check this on your site and give you a feasible solution.

Kind regards
Raja

September 3, 2019 at 9:15 am #4502447

mohammedJ-10

Hello, Thanks for the reply. Before sharing the access could you please confirm me:

> Duplication content: Can we display the content without using the duplication feature?
- I selected "Post Types Translation" "Translatable - use translation if available or fallback to default language" but content does not appear still

> For the 2 part I'm confused about what should i do

Hope you can help me & Tks for the support!

September 3, 2019 at 11:17 am #4503871

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Let's forget about the second issue, for the time being, we can deal with that later.

The option "Translatable - use translation if available or fallback to the default language. will only work if you have created the post in the default language.

For example: If your site default language is English and Secondary Language is French, The option will only work if you have created the post in Site Default language which is English in this case. If the posts are created in Secondary language the fallback option does not work.

Can you please confirm whether the posts and pages are created in site default language?

Also, let me know the URL where the issue can be seen. If the fallback option is not displaying content as exected do you any error or just a blank screen?

September 3, 2019 at 1:49 pm #4505009

mohammedJ-10

My issue is resolved now. Thank you!