This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Diego Pereira 1 year ago.

Assigned support staff: Diego Pereira.

Author Posts
October 11, 2018 at 9:33 am #2807362

adilA-3

Tell us what you are trying to do?
Trying to translate to the RTL layout arabic language using the footer plugin for WPML. I already have the translated content but using the + sign and adding and updating the transation page does not translate. I need to translate all items in the theme. My theme is WPML compatible, I checked before I bought... LMS (by Design Themes )

Is there any documentation that you are following?
No
Is there a similar example that we can see?
yes
hidden link
hidden link

What is the link to your site?
hidden link

October 11, 2018 at 5:38 pm #2809331

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @adila-3, welcome to the WPML support Forum!

I checked this page: hidden link - Apparently the direction is correct (RTL), but the strings are still displayed in English. Have you already modified these strings?

To translate page content
- Go to the edit screen of the page (default language)
- Click on the "+" icon on the right sidebar to create a new translation
- FIll all fields with the translated text, check all "Translation is complete" fields and save

To translate the strings of the theme:
- Make sure you have the Translation Magagement and String Translator extensions active. If not, you can download here: https://wpml.org/account/downloads/
- Go to WPML > Theme and Plugin Localization > Strings in the themes
- Select your theme and click on Scan selected theme for strings
- Go to WPML > String Translation and search for the Strings
- Translate the string, check the Translation is complete field and click on Save.

Ref: https://wpml.org/documentation/getting-started-guide/string-translation/

If you can not find the strings, check it is possible to find it on the Translate texts in admin screen page, like on this link: https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts

I also checked the settings of your server through debug log and saw that some items need attention:
Increase WP memory
Please increase the PHP memory limit to 256mb. Currently this memory is set to 40mb only.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

PHP Version
Upgrade from PHP to version 7 or higher. This is a practice recommended by the WordPress.org website: https://wordpress.org/about/requirements/

MaxInputVars
Currently your server is configured with MaxInputVars = 1000, which is too low and can cause problems. Please increase this to 10,000. There are two options to do this:
== php.ini file
Open the php.ini file and insert/edit this line:

max_input_vars = 10000

hidden link
== .htaccess file

php_value max_input_vars 10000

Please let me know if it worked for you.

All the best,
Diego