This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: A theme or plugin is overriding a theme option on translated pages to the value on the original post. This option is stored as a custom field set up by the theme.

The custom field is being overridden by the original post value for that field. This indicates that the field is set to "Copy" by the theme's WPML Config File.

Solution: The setting by the theme can be changed by going to WPML -> Settings and scrolling down to the Custom Field Translation section. The affected custom field must be set to "Translate" or "Copy Once", instead of "Copy".

Relevant Documentation: https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by mustafaH-2 3 weeks, 2 days ago.

Assigned support staff: Izzi Hassan.

Author Posts
September 23, 2019 at 7:47 am

mustafaH-2

I am trying to: Trying to translate the English version to Arabic version but its appeared that only one language allow to use. In my home page WP-dashboard Admin there's an option to choose the slider you want, what I did was I create two different slider one for English and One For Arabic. Now the problem here is only one slider allowed to choose if I choose the English Version it will appeared also in Arabic version same if I choose Arabic version as well.

Link to a page where the issue can be seen: Home Page - hidden link

I expected to see: When I choose the English Version it should be English Version ofcourse and if Choose arabic Arabic version will appear in the webiste.

Instead, I got: One language version only allow.

Note: If you notice in Arabic Version in screenshot I already choose Arabic but when I save, It will automatically back to Primary Language of the website which it English Version Slider.

September 23, 2019 at 2:37 pm #4625073

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for providing access to your website. I took a look and found that the theme you are using is causing this through a WPML setting that forces the Rev Slider field to ALWAYS be copied over from the original (English) language page or post. This is why you see the field revert to the English slider.

You can change this setting by following the steps below:

  • Go to WPML -> Settings and scroll down to the “Custom Fields Translation” section
  • Search for “ple-mediapanel-revslider” and change the option from “Copy” to “Copy Once”. This will allow you to modify the Media Panel -> Revolution Slider settings on any translated page or post

Next, you need to update the translated (Arabic) page again. The page also has a setting for that option. Please make sure that setting is also set correctly. I have provided screenshots illustrating the correct option.

Finally, you can select the “Home Page Arabic” slider from the dropdown. If the slider does not update, you may also need to update the custom field directly, using the short name for the slider: “home-page-arabic”. I have also provided a screenshot showing the correct value for this field.

Please try to fix the issue and let us know how it goes. I will be happy to make the changes for you if you have further issues, but we try to avoid modifying live sites where possible.

September 24, 2019 at 7:10 am #4628507

mustafaH-2

My issue is resolved now. Thank you!