This thread is resolved. Here is a description of the problem and solution.

Problem: Uncaught Error: WPML_Jobs_Fetch_Log_UI

Solution: Updating to the latest version manually solved the issue.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Pablo 8 months, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
September 17, 2019 at 1:36 pm #4588893

An error of type E_ERROR was caused in line 46 of the file */wp-content/plugins/wpml-translation-management/menu/wpml-tm-menus-management.php. Error message: Uncaught Error: Class 'WPML_Jobs_Fetch_Log_UI' not found in */wp-content/plugins/wpml-translation-management/menu/wpml-tm-menus-management.php:46 Stack trace: #0 */wp-content/plugins/wpml-translation-management/classes/class-wpml-translation-management.php(62): WPML_TM_Menus_Management->__construct(Object(WPML_Twig_Template), Object(WPML_Translation_Manager_Records), Object(WPML_Translator_Records)) #1 */wp-content/plugins/wpml-translation-management/plugin.php(74): WPML_Translation_Management->init() #2 */cheesysupply/wp-includes/class-wp-hook.php(286): wpml_tm_load(Object(SitePress)) #3 */wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #4 */wp-includes/plugin.php(465): WP_Hook->do_action(Array) #5 */wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php
September 18, 2019 at 6:31 pm #4599531


the above error appeared after WPML upgrade.

September 19, 2019 at 5:08 am #4601331

Shekhar Bhandari

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

It looks like there was some problem with the installation, can you please manually install the latest version of WPML plugins and let me know if this helps?

❌ Backup your website and database ❌
• Deactivate/Delete the “Installer” plugin (if you have it)
• Deactivate all WPML plugins
• Login via FTP to your wp-content/plugins folder
• Delete all WPML folders
• Go to and download the latest stable WPML Multilingual CMS Plugin, then extract it.
• Upload the plugin via FTP to the wp-content/plugins folder.
⌥ alternatively you could upload the .zip file using Dashboard > Plugins > New > Upload
• Activate the WPML plugin via WP Dashboard > Plugins
• Complete the setup, if needed
• Register WPML for your site (at the end of setup, click on “generate key” button)
• Navigate to Dashboard > Plugins and locate WPML Multilingual CMS
• Click on the blue link that says “Registered”
• Download and activate all needed WPML AddOn Plugins

This should not generate any problems.

⌥ In case you want to register WPML for your site manually please make sure to enter the naked URL of your site in (something like hidden link)

⌥ In the extreme case, please try to register with all non-WPML Plugins deactivated,
and Theme Twenty sixteen enabled.

Look forward to your reply.


September 19, 2019 at 11:48 am #4604351


My WinSCP program did not upload all files to the server.
Yesterday I updated this program, copied the plugins again to the server and the site works.
Thank you!