This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.85 hours from now. Thank you for your understanding.

This topic contains 7 replies, has 2 voices.

Last updated by Laura 3 months, 1 week ago.

Assigned support staff: Laura.

Author Posts
July 10, 2019 at 1:14 pm #4180617

lisa-annP-2

Tell us what you are trying to do?

Hi there, so I'm trying to install WPML for the fifth time by now and it does not seem to be working. I was using qTranslateX, but since the plugin doesn't seem to work for me, I wanted to do it without and migrate everything manually. But I keep getting error messages.

Is there any documentation that you are following?

The ones from WPML.

Is there a similar example that we can see?

No.

What is the link to your site?

hidden link

I get this error message when I try to finish the set up for WPML:

Uncaught exception 'InvalidArgumentException' with message 'element_id and type do not match for element_id:334 the database contains tax_post_tag while this function was called with tax_translation_priority' in /home/httpd/vhosts/radtke-messtechnik.com/lp-demo.radtke-messtechnik.com/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php:32 Stack trace: #0 /home/httpd/vhosts/radtke-messtechnik.com/lp-demo.radtke-messtechnik.com/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php(1490): WPML_Set_Language->set(334, 'tax_translation...', NULL, 'de', NULL, true) #1 /home/httpd/vhosts/radtke-messtechnik.com/lp-demo.radtke-messtechnik.com/wp-content/plugins/sitepress-multilingual-cms/classes/taxonomy-term-translation/class-wpml-term-actions.php(47): SitePress->set_element_language_details(334, 'tax_translation...', NULL, 'de', NULL) #2 /home/httpd/vhosts/radtke-messtechnik.com/lp-demo.radtke-messtechnik.com/wp-content/plugins/sitepress-multilingual-cms/ in /home/httpd/vhosts/radtke-messtechnik.com/lp-demo.radtke-messtechnik.com/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php on line 32

I can't provide WPML Debug info since I couldn't activate it.

July 10, 2019 at 2:56 pm #4181757

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

If I try to access the admin area, I get this error: Du bist leider nicht berechtigt, auf diese Seite zuzugreifen.

Are you using some plugin to restrict access?

July 10, 2019 at 3:04 pm #4181927

lisa-annP-2

Not that I know, i tried adding /wp-admin and used my credentials, do you need them? I can't access the site either, but I can access the backend. So you could check the plugins.

July 10, 2019 at 3:08 pm #4181997

lisa-annP-2

Whenever I try looking at a website it says "The theme directory "buildpress" does not exist." Buildpress is the theme, I don't know why it is missing.

July 11, 2019 at 7:38 am #4186775

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

the theme is missing because I disabled it while trying to access the site.

In the debug log I see:

PHP Notice:  Undefined index: input in /mnt/BLOCKSTORAGE/home/219772.cloudwaysapps.com/maucekzcqq/public_html/wp-includes/kses.php on line 1155

so I'm trying to understand what is causing it.

July 12, 2019 at 7:15 am #4195775

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

sorry for the delay in replying. I could successfully run an import from qTranslate to WPML, and I have no database errors.

This was my process and you could try this too:
- starting with a copy of the site WITHOUT WPML
- deactivate all plugins
- switch to a standard theme like Twenty Nineteen
- deactivate qTranslate (not the importer)
- install WPML, activate and configure it
- when I first tried to run the importer, I got this message "Please save the qTranslate settings to the datbase first. Go to Languages Tab of Qtranslate settings Edit the languages that are active & enabled and update their names to something, save and revert back."
- so I enabled qTranslate again, went to the setting page and added the language code in "frontend locale"
- disabled qTranslate again
- now I can run the importer successfully

You can see the results here: hidden link
Please notice that something has to be edited manually because the converter doesn't work for page builders contents or other 3rd party plugin - for example I see you have a plugin to change the "add to cart" button, WPML couldn't pick that one.

Can you tell me if you manage to succeed following these steps?

July 12, 2019 at 7:19 am #4195919

lisa-annP-2

Hi Laura, thanks so much for this guidance. One question though:

- so I enabled qTranslate again, went to the setting page and added the language code in "frontend locale"

Could you show me a picture of "added the language code in "frontend locale"?

Thanks!

July 12, 2019 at 8:46 am #4196535

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Here