This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Bigul 7 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
February 27, 2019 at 1:38 pm

kasperG

I am trying to:

I cannot edit my pages anymore. I get the following error:

Fatal error: Uncaught TypeError: Argument 1 passed to WPML_TM_ATE_Job_Repository::is_ate_job() must be an instance of WPML_TM_Post_Job_Entity, instance of WPML_TM_Job_Entity given in /home/stifinde/public_html/stifinder.com/wp-content/plugins/wpml-translation-management/classes/ATE/models/class-wpml-tm-ate-job-repository.php:32 Stack trace: #0 [internal function]: WPML_TM_ATE_Job_Repository->is_ate_job(Object(WPML_TM_Job_Entity)) #1 /home/stifinde/public_html/stifinder.com/wp-content/plugins/wpml-translation-management/classes/jobs/class-wpml-tm-jobs-collection.php(43): array_filter(Array, Array) #2 /home/stifinde/public_html/stifinder.com/wp-content/plugins/wpml-translation-management/classes/ATE/models/class-wpml-tm-ate-job-repository.php(24): WPML_TM_Jobs_Collection->filter(Array) #3 /home/stifinde/public_html/stifinder.com/wp-content/plugins/wpml-translation-management/classes/ATE/Hooks/class-wpml-tm-ate-jobs-sync-script-loader.php(24): WPML_TM_ATE_Job_Repository->get_in_progress() #4 /home/stifinde/public_html/stifin in /home/stifinde/public_html/stifinder.com/wp-content/plugins/wpml-translation-management/classes/ATE/models/class-wpml-tm-ate-job-repository.php on line 32

Link to a page where the issue can be seen:
hidden link

I expected to see:
Editing page

Instead, I got:
Error. See above.

February 28, 2019 at 8:43 am #3254100

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Does it happen after upgrading to WPML 4.2.2 or 4.2.3? Please visit WPML>>Settings and choose *Use WPML's Classic Translation Editor* option for *How to translate posts and pages* and make sure the issue is existing or not.

I have a request. Please upgrade the following configuration for the expected performance of your site and check is there any difference in the result.

1) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

2) Increase the *MaxInputVars* of PHP settings to *5000* or more. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

--
Thanks!

Bigul

February 28, 2019 at 11:31 am #3254880

kasperG

Hello Begul

Thank you for your kind reply.

I am not completely sure when the issue arose. But I think it was after an update.

I have increased both memory and maxinputvars. See attached. I still get the error however.

When I enable "WPML>>Settings and choose *Use WPML's Classic Translation Editor*" the error disappears.

I can see others are experiencing the same issue:
https://wpml.org/forums/topic/fatal-error-after-updating-wpml-2/

Let me know how we can solve this quickly. The site is crippled as of now.

February 28, 2019 at 6:11 pm #3256999

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. We have escalated this ticket to our developers and have a workaround for this issue. Please try the following steps after a full site backup and let me know your feedback.

1) Visit *wp-content/plugins/wpml-translation-management/classes/ATE/models/* folder
2) Open *class-wpml-tm-ate-job-repository.php* file for edit
3) Scroll down to line 36 and make the following change

From

'job_type' => WPML_TM_Job_Entity::POST_TYPE,

To

'job_types' => WPML_TM_Job_Entity::POST_TYPE,

--
Thanks!

Bigul

March 1, 2019 at 7:14 am #3258701

kasperG

Hi Bigul

Thank you. This solved the issue. It's working now.

Will this be fixed in a future update to the plugin?

Kind regards

March 1, 2019 at 3:32 pm #3261929

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. The fix will be included in the next version of WPML. Please check the following errata URL for more details.

https://wpml.org/errata/ate-triggers-a-fatal-error-after-wpml-4-2-2/

--
Thanks!

Bigul

March 5, 2019 at 7:13 am #3271845

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, we have released a new version of WPML Translation Management(2.8.3). It has included the fix for the issue. Please upgrade to the latest version after a site backup and check.

Please check the following links for more details.

https://wpml.org/download/wpml-translation-management/?section=changelog

https://wpml.org/errata/ate-triggers-a-fatal-error-after-wpml-4-2-2/

--
Thanks!

Bigul