This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Uncaught TypeError: Fatal error: Uncaught TypeError: Argument 1 passed to WPML_Slash_Management::parse_missing_host_from_path() must be of the type array, boolean given, called in /home/forconf6/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling/converter/strategy/class-wpml-url-converter-domain-strategy.php on line 101 and defined in /home/forconf6/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/utilities/class-wpml-slash-management.php:110 Stack trace: #0 /home/forconf6/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling/converter/strategy/class-wpml-url-converter-domain-strategy.php(101): WPML_Slash_Management->parse_missing_host_from_path(false) #1 /home/forconf6/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling/converter/strategy/class-wpml-url-converter-domain-strategy.php(29): WPML_URL_Converter_Domain_Strategy->strip_protocol('https:///') #2 /home/forconf6/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling in /home/forconf6/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/utilities/class-wpml-slash-management.php on line 110

Solution:

-backup your site completely
-go to 'wpl1_options' table and search for "icl_sitepress_settings"
There edit the key and change:

s:25:"language_negotiation_type";s:1:"2";

to:

s:25:"language_negotiation_type";s:1:"1";

Then go to WPML > Languages and set "Different domain per language" and ENTER A VALID domain for ALL LANGUAGES. The problem happens because there is NO domain for the second language.

Tagged: 

This topic contains 8 replies, has 3 voices.

Last updated by maximilianoD-3 6 months, 3 weeks ago.

Assigned support staff: Dennis.

Author Posts
February 25, 2019 at 10:03 am #3238854

marcV-45

I am trying to: work in the wpml plugin. Website went down.

Link to a page where the issue can be seen: no link available. Message show on url: Uncaught TypeError: Fatal error: Uncaught TypeError: Argument 1 passed to WPML_Slash_Management::parse_missing_host_from_path() must be of the type array, boolean given, called in /home/forconf6/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling/converter/strategy/class-wpml-url-converter-domain-strategy.php on line 101 and defined in /home/forconf6/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/utilities/class-wpml-slash-management.php:110 Stack trace: #0 /home/forconf6/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling/converter/strategy/class-wpml-url-converter-domain-strategy.php(101): WPML_Slash_Management->parse_missing_host_from_path(false) #1 /home/forconf6/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling/converter/strategy/class-wpml-url-converter-domain-strategy.php(29): WPML_URL_Converter_Domain_Strategy->strip_protocol('hidden link') #2 /home/forconf6/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling in /home/forconf6/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/utilities/class-wpml-slash-management.php on line 110

I expected to see:

Instead, I got:

February 26, 2019 at 4:37 am #3243094

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

Could you please tell me more about the issue? Are you able to access the backend now? Did the issue appeared when you try to install WPML?

I suppose you haven't done any translation yet..right? Please confirm.

If that's the case, I would recommend re-installing WPML and its addon plugins. Before re-installing WPML your have to RESET it first. To do it please follow these steps.

NOTE: Please make secure a complete backup of your site before proceeding anything.

-Go to WPML>>Support page
-Click on Troubleshooting link (link in the middle of the page)
-head down to the bottom of the page. On the 'Reset' section, click 'I am about to reset all translation and language data.'
-click 'Reset and deactivate WPML'

-on Plugins page, deactivate all other WPML plugins.
-Delete all WPML plugins.
-download fresh copies of WPML plugin at wpml.org
-install/activate WPML

Does it help? Please let me know.

Kind regards,
Dennis

March 4, 2019 at 8:33 am #3267470

marcV-45

Hi,

We are able to access the backend after restoring the backup off the website. We deleted the WPML plugin, because we did get the same error. So we can't provide the debug information. The translated pages are still in the overview. We didn't reinstall the plugin yet. By the way when I open the support page I don't see the troubleshooting link.

March 4, 2019 at 9:50 am #3267824

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

I would like to request temporary access (/wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. Your next reply will be set to private.

Maybe I'll need to replicate your site locally to continue debugging and escalate if necessary. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please confirm if this okay with you.

Our Debugging Procedures
I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to BACKUP the site before providing us access.

Privacy and Security Policy
We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Kind regards,
Dennis

March 7, 2019 at 3:11 am #3282083

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for providing us with the access details.

I downloaded a copy of your site and was able to reproduce the issue. It seems that there is an interaction issue with your theme which is causing the problem.

I will consult our specialists about this issue and I will get back to you as soon as I have an answer.

Kind regards,
Dennis

March 8, 2019 at 1:59 am #3288222

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

I have escalated this to our 2nd Tier Support team. They will further examine the issue to find the cause and resolution. I will keep you updated here.

Thank you.

Kind regards,
Dennis

March 11, 2019 at 7:03 am #3308011

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for waiting.

Our 2nd tier found out that the issue occurred when setting Language URL format to 'Different domain per language' and entered an invalid domain for one the language domain.

To fix the issue,

-backup your site completely
-go to 'wpl1_options' table and search for "icl_sitepress_settings"
There edit the key and change:

s:25:"language_negotiation_type";s:1:"2";

to:

s:25:"language_negotiation_type";s:1:"1";

Then go to WPML > Languages and set "Different domain per language" and ENTER A VALID domain for ALL LANGUAGES. The problem happens because there is NO domain for the second language.

Let me know if you can handle this else you can install "ARI Adminer" plugin to your live site and after a full back up your site, provide us with the FTP access and permission to perform the action. I have enabled the private fields to securely share the requested details.

Kind regards,
Dennis

March 26, 2019 at 10:02 am #3461203

marcV-45

My issue is resolved now. Thank you!

May 10, 2019 at 9:34 am #3782821

maximilianoD-3

hi there i have the same issue .. but where i find wpl1_options????