This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by jacobN-2 2 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
August 8, 2019 at 7:14 am

jacobN-2

I am trying to: Translate icon boxes.

Link to a page where the issue can be seen: hidden link (on the front-page, right below the header)

I expected to see: Translated icon boxes

Instead, I got: Icon boxes are not translated. They are not available when I translate a page.

August 8, 2019 at 8:36 am #4361009

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Here are WPBakery Page Builder modules that are supported by WPML and will automatically be displayed on the Translator Editor page:
- https://wpml.org/documentation/translating-your-contents/page-builders/#supported-modules

And here is a guide on how to make custom VC element WPML translation editor compatible:
- https://wpml.org/documentation/support/wpml-integration-with-page-builders-that-use-shortcodes/
- https://wpml.org/documentation/support/language-configuration-files/

Please follow below steps in order to enable Iconbox translation:

1. Please add below XML in WPML >> Settings >> Custom XML Configuration section:

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>iconbox</tag>
            <attributes>
                <attribute>title</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

2. Edit the translation and finish it as it is (mark it as 100% Translated).

3. Make a small change in the original page, for example, a space in your title.

4. Edit the translation again.

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

August 8, 2019 at 10:40 am #4361893

jacobN-2

Thank you for your response!

I followed your instructions, unfortunately it still does not translate the icon boxes

August 8, 2019 at 1:49 pm #4363441

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have logged in to your site and used correct tag name in XML and now Iconbox fields are available for translation in translation editor. Could you please check and confirm?

Thank you

August 8, 2019 at 10:12 pm #4366197

jacobN-2

My issue is resolved now. Thank you!