This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Marcel 1 month ago.

Assigned support staff: Marcel.

Author Posts
September 12, 2019 at 3:17 pm #4562319

francoisR-2

I want to use the translation service but the translation manager plugin is not working as expected, i regulary get the following php error ( see picture )in the backoffice only.

All plugins and wordpress are up to date, php ver 7.1.29.

I don't know where to start to resolve this error.
Do you have any idea ?

September 12, 2019 at 3:48 pm #4562625

francoisR-2

Hi,

I've try to deactivate all the plugins but wpml, the error still occured.

September 12, 2019 at 4:04 pm #4562893

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

Thank you for contacting WPML Support.

I would eventually also need to request temporary access (WP-Admin and FTP) to your site
– preferably to a test site where the problem has been replicated if possible –
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

✙ Please add the Links to the URL where you see the these Strings.

Thank you

Best Marcel

September 13, 2019 at 7:56 am #4566253

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

#1 I deactivated Translation Management
#2 Increased your WP Memory Limit
#3 Re-installed Translation Management over Plugins -> Add New -> Commercial
- Then I removed the old Translation Management version from your site

Now it's working without any errors.

Best Marcel

September 13, 2019 at 9:39 am #4567055

francoisR-2

Hi,

Thanks but the error is still here...
I saw that you turned off WP_DEBUG. I reactivated it.
If you go back to wp-admin and navigate a bit, you will saw the error again.

I redeclare the WPML_TM_FOLDER constant in wp-config.php and i added the following condition

if ( ! defined( 'WPML_TM_FOLDER' ) ) {
define('WPML_TM_FOLDER', basename(WPML_TM_PATH));
}

at the first line of the file wp-content\plugins\wpml-translation-management\inc\constants.php
I know it's not a good practice but this way, the first part of the error is gone.

Now it still remain the second error "Class 'WPML_Translation_Management' not found".

I'm still searching a solution.

September 13, 2019 at 10:10 am #4567317

francoisR-2

Ok,

I've found a temporary solution:

1 - i've replace the line 7 of the file wp-content\plugins\sitepress-multilingual-cms\classes\utilities\admin\class-wpml-admin-url.php

$url = admin_url( 'admin.php?page=' . WPML_TM_FOLDER . WPML_Translation_Management::PAGE_SLUG_SETTINGS . '&sm=mcsetup' );

by this one :

$url = admin_url( 'admin.php?page=' . WPML_TM_FOLDER . '/menu/settings&sm=mcsetup' );

where "'/menu/settings" is what is define in wp-content\plugins\wpml-translation-management\classes\class-wpml-translation-management.php at line 8; nothing more than the value of WPML_Translation_Management::PAGE_SLUG_SETTINGS.

The error does not appear again.

I know that at next update the error will be back, so it's a temporary solution.

i'm interested in any other solution.

September 13, 2019 at 4:31 pm #4570077

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

yes, after testing I turned WP_DEBUG off. I can't access the Staging now anymore, could you please check this?

The topic ‘[Closed] undefined constant WPML_TM_FOLDER – Class 'WPML_Translation_Management' not foun’ is closed to new replies.