This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by dominikM-16 1 month, 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
April 3, 2020 at 12:06 pm #5831591

dominikM-16

I am trying to:
Get rid of warning/error message

Link to a page where the issue can be seen:
localhost (can provide external url if needed)

I expected to see:
No warning or/and error messages

Instead, I got:
Warning or/and error messages

I am not sure if it matters more, but I would like to be sure that on the page I create for my client everything works as it should.

When I enable:

define ('WP_DEBUG', true); 

I get a large number of warnings / errors as per the attached screenshot.

I kindly ask you to solve this problem.

April 5, 2020 at 12:32 am #5839709

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Do I see right, that the website only uses ACF Pro and WPML? Do you get the same error when switching to the parent theme?

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

April 6, 2020 at 7:51 am #5845049

dominikM-16

Hi Andreas, thanks for your answer.
Switching to parent theme did nothing, I still see error messages. As for plugins, I temporarily disabled all but the necessary ones to test if errors will still occur.

Unfortunately, I don't see the fields needed to enter login details for wp-admin / FTP. Did I miss something?

April 7, 2020 at 2:11 pm #5858163

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

I am sorry about the inconvenience. The private fields are enabled again.

Please also add server access details for enabling wp-debug.
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

April 7, 2020 at 8:35 pm #5860851

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I do currently not see any errors on your site.

Could it be that the error was solved after making some updates? I also enabled the debug.log but I was visiting the site and nothing was gathered so far.

In order to trace the error, I need to know what triggers it. Do you see any functional issues when it comes to create and translate Advanced Custom Fields PRO?

Kind regards
Andreas

April 8, 2020 at 7:53 am #5863191

dominikM-16

This is really weird but you're right - it looks like there is no errors on "Theme Options" page anymore but I had them just 2 days ago (see screenshot).

In fact, I had several problems translating the field repeater: I had to check the "copy once" box, though here: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#setting-repeater -and-flexible-fields-translation-preferences there is an instruction that I should check the "copy" box, not "copy once".

When I checked the "copy" box, the repeater did not appear on the translation page. Maybe there is a problem here?

In any case, if will not observe this error, I will mark the problem solved, apparently error "fixed itself" 😉

April 8, 2020 at 7:46 pm #5869699

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

In fact, the fields should be able to set to "copy" or even "copy once" and besides the system fields need to be set to "copy".

https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#setting-repeater-and-flexible-fields-translation-preferences

Now, I do understand right, that the fields do not work when you use "copy" instead of "copy once"? Could you test if the error appears again when taking those changes, please?

Kind regards
Andreas

April 9, 2020 at 7:59 am #5872981

dominikM-16

Due to the fact that errors have stopped appearing, I mark issue as solved. Thank you for your help.