We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Carlos Rojas 3 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 22, 2019 at 3:04 pm

Ashley

I am trying to add products to the cart in English at hidden link

Link to a page where the issue can be seen: hidden link

I expected to see: All products add to cart.

Instead, I got a pop-up after adding a couple of products asking to switch language and clear the cart.

July 23, 2019 at 2:41 am #4262283

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps:
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Select the 'Synchronize cart content when switching languages' options -> Save the changes.
- Go to WPML -> Languages -> Activate the Ajax cookie -> Save the changes.

Could you confirm that the issue is solved?

2.- Please update all outdated plugins and themes, specially WPML plugins. Outdated functionalities can cause conflicts in the code.

3.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos