This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by florianG-22 2 months ago.

Assigned support staff: Bobby.

Author Posts
August 14, 2019 at 2:16 pm

florianG-22

I am trying to:
access a post, which is redirecting to a page

Link to a page where the issue can be seen:
the post /organisationsentwicklung/
is redirecting to /beratung/organisationsentwicklung/
although the post /organisationsentwicklung/ still exists and has not been deleted/changed/edited

If I deactivate WPML plugin, this issue is gone.

August 14, 2019 at 7:49 pm #4397247

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

checking the URL i can see a 301 redirect applied

<em><u>hidden link</u></em>

HTTP/1.1 301 Moved Permanently
Date: Wed, 14 Aug 2019 19:37:22 GMT
Content-Type: text/html; charset=UTF-8
Content-Length: 0
Connection: keep-alive
Server: Apache
Set-Cookie: PHPSESSID=03bb55582f5e290fb3bd576a5f02711f; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate
Pragma: no-cache
X-Redirect-By: WordPress
Location: <em><u>hidden link</u></em>
Strict-Transport-Security: max-age=31536000
X-Cache-Status: MISS

<em><u>hidden link</u></em>

There is a page named Organisationsentwicklung with a parent "Beratung" within your pages and you also have the post in question which is named "Organisationsentwicklung" as well

this is what is causing issues.

renaming the permalink for the post or the page will resolve the issue

for example i have renamed the permalink for the post "Organisationsentwicklung" to
hidden link

and it works as expected.

P.S when using WPML you can use any permalink structure within WP->Settings->Permalinks except the default or pretty links (first option)

August 15, 2019 at 5:11 am #4399143

florianG-22

Hi Bobby,

yes, I know that.

My point is:

1. The 301 redirection that you mention did not happen before I installed WPML. The post /organisationsentwicklung" ranked No 2 in Google for the term.

2. If I deactivate WPML, the redirection is gone.

So my conclusion is:
WPML is causing this redirection!

For now, I have deactivated WPML and renamed the post /organisationsentwicklung/ to the old slug, so you can see that my statement is correct.

I consider this a bug - or something in the database is screwed up, which is causing WPML to act weird.

WPML should never ever cause unwanted redirects! Because this will hurt any sites SEO. Not good, not acceptable. Do you agree on this?

Please work with me to resolve the issue. The objective from my point of view should be:
- to find the root cause why WPML is causing this problem
- to find a way that WPML is activated, and the redirect will not happen (without changing the URL, which I consider a workaround, but not a real solution).

Can you please help me with this?

Best
Florian

August 15, 2019 at 5:31 pm #4402695

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

This is a known issue that has been escalated to our developers and it is added to our list for feature updates

please read my answer in the following thread and try the solution i have provided.

=> https://wpml.org/forums/topic/where-can-i-see-and-manage-redirects-within-wpml/page/2/#post-4292973

please do keep in mind that the solution i have provided is a temporary solution and an overall fix will be introduced in the future versions of WPML

if the above solution does not work please use the workaround i provided in the first message of renaming the URL

let me know your results

August 15, 2019 at 7:31 pm #4403173

florianG-22

My issue is resolved now. Thank you!

September 11, 2019 at 6:19 am #4550793

florianG-22

(posted by mistake)