This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to an add item to basket, then add another and go to chekout in French. Instead, I got unexpected switching from French language to Russian

Solution: In this case the most probable cause for the issue is an outdated cache memory, which is probably in your browser so clients won't see the problem.

However I recommend you to contact your hosting providers and ask them to flush any cache memory that might exists at server level.

Relevant Documentation:

This topic contains 7 replies, has 2 voices.

Last updated by Carlos Rojas 3 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 11, 2019 at 11:21 am #4189139

Dmitry

I am trying to: add item to basket, then add another and go to chekout in French

Link to a page where the issue can be seen: hidden link

I expected to see: the continuation of the checkout process in French

Instead, I got: unexpected switching from French language to Russian

July 11, 2019 at 2:09 pm #4190717

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I would like to ask you to follow this steps:
- Create a full backup of the site.
- Update all outdated plugins and themes.
- Flush all cache memory that might exists.
- Go to Woocommerce -> Woocommerce Multilingual -> Status tab -> Fix any error that might appear.
- Go to Woocommerce -> Wooocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Select all options -> Click on the 'Start' button.
- Go to Pages -> Make sure all Woocommerce pages are translated.
- Go to WPML -> Support -> Trobleshooting link -> Apply the troubleshooting steps pointed out in the attached image.

Could you confirm that the issue is solved?

Kind regards,
Carlos

July 11, 2019 at 5:25 pm #4192359

Dmitry

Dear Carlos, I have made all the steps you have advised. But error of switching from French language to Russian comes immediately when I try choose first product.
You can check it on page: hidden link

July 11, 2019 at 7:33 pm #4192879

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message.

I followed the steps you described to reproduce the issue however the site worked correctly. I wasn't able to reproduce the issue.

Have you tried to reproduce the issue on incognito mode?

Regards,
Carlos

July 12, 2019 at 6:52 am #4195563

Dmitry

Dear Carlos, I've tried to reproduce the issue on incognito mode and translations works correctly without unexpected switching from French language to Russian.
What I should do or recommend to our customers to avoid unexpected switching in future?
Thank You!

July 12, 2019 at 1:26 pm #4199333

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

In this case the most probable cause for the issue is an outdated cache memory, which is probably in your browser so clients won't see the problem.

However I recommend you to contact your hosting providers and ask them to flush any cache memory that might exists at server level.

Regards,
Carlos

July 16, 2019 at 3:15 pm #4221637

Dmitry

My issue is resolved now. Thank you!

July 16, 2019 at 3:17 pm #4221657

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos