This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by nunom-12 5 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 10, 2019 at 9:06 am #3782479

nunom-12

Hi.

In the menu all words with (Ç, Á, Õ ...) are left with unknown characters.

I do not know if the problem is in wpml or in theme.

Thanks

May 10, 2019 at 11:28 am #3783715

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

It looks like you are having some kind of encoding issue. Have you checked that your database has been correctly set and it uses same character encoding?

You can also try to change the following parameter in your wp-config.php file:

define('DB_CHARSET', 'utf8mb4');

For:

define('DB_CHARSET', 'utf8');

Let me know how that goes!

Thanks

May 14, 2019 at 11:11 am #3806241

nunom-12

Hi.

I had already made this change but everything was the same.

May 15, 2019 at 3:34 am #3811921

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

That seems unusual, would you mind providing me login details, so I can quickly check your settings once? for this, I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

May 16, 2019 at 4:59 am #3821983

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

To further debug this issue, I am creating a duplicator package on your site. I will create a package, replicate the site in my localhost for further debugging and will respond to you soon.

Thanks

May 16, 2019 at 11:10 am #3825245

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I replicated your site on my localhost and I couldn't reproduce the issue on my localhost. Being so to be further help, I am currently discussing this issue with our 2nd tier supporters and respond to you soon.

Thanks

May 17, 2019 at 3:36 am #3831171

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Since it's not replicated on localhost, I request you to please follow the below steps:

- Disabling WPML
- Changing language to Portuguese
- See if the character problem exists.

Further, if you can create a staging site, it would be helpful so we can test this issue.

Look forward to your reply.

Thanks

May 17, 2019 at 10:51 am #3833599

nunom-12

My issue is resolved now. Thank you!