This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Riffaz 8 months, 1 week ago.

Assigned support staff: Riffaz.

Author Posts
February 8, 2019 at 11:13 am #3174762

fabioD-21

Hello,

since all the plugins updates worked on our clone site areatest.stefaniaesse.com, today we've updated on stefaniaesse.com too. Something wrong might have occurred because it has appeared the following messagge with the suggestion to contact you to solve it: "Unknown column 'translation_priority' in 'field list'".

What shall we do?

Many thanks.

All the best.

Fabio

February 10, 2019 at 7:43 am #3179371

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

#1

I see your memory limit is 512MB but youe WP Memory is 40MB

Please increase the WP Memory Limit (because your current setting is 40M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

- Add it above the line

/* That's all, stop editing! Happy blogging. */

#2

For some reason, it seems that somehow the ‘translation_priority’ field is missing from _icl_strings table.

To confirm this, please try the following steps:

-Backup your site Completely (important!).

-Login to MySQL via PHPMyAdmin or similar tool.

-Choose your database.

-Run the following query. Please note your table prefix may be different(wp_icl_strings).

ALTER TABLE wp_icl_strings ADD COLUMN translation_priority varchar(160) NOT NULL;

If you still see the issue,
Maybe this is a problem with your site's cache and so the message still appears, even though the column already exists. Is your server using any cache?

If yes, please could you clear the cache and verify that the problem persists?

If the problem persists, please as a test, could you disable all non-WPML plugins, switch to the default theme (e.g. TwentySixteen) and see if the problem persists? Please secure a complete backup of your site before doing this test.

If the problem is fixed, please, enable the plugins one by one to see if there is any compatibility problem between these plugins.

Please let me know how it goes.

Kind regards,
Riffaz.