This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by markoP-4 4 months, 3 weeks ago.

Assigned support staff: Bruno.

Author Posts
May 13, 2019 at 3:57 pm #3800375

markoP-4

Hi,

After updating WP to 5.2 and WPML to 4.2.6, I'm getting this error

Unknown column 'translation_priority' in 'field list'

translation_priority is in the database, I've cleared WPML cache but error still persist. How can I resolve this issue?

Thanks

May 14, 2019 at 12:13 am #3802311

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you for contacting us. Although the error is slightly different, the solution on our errata page probably should work: https://wpml.org/errata/missing-_icl_strings-_icl_string_translations-data-tables/

Please, before following the steps of our errata page, back up your database. After following these steps, please let me know if the problem still persists.

Thank you.

May 17, 2019 at 4:05 pm #3835901

markoP-4

Hi,

This doesn't solve the issue.

What can I do next?

Thanks

May 17, 2019 at 8:35 pm #3836855

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Could I install the Adminer plugin so I can check your database?

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

May 21, 2019 at 11:51 pm #3859215

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you. I looked in your database and I noticed that the "translation_priority" column has already been created in the database (_icl_strings). Maybe this message is just a cache and so it is still being displayed.

On your production site, please go to the database and look at the "_icl_strings" table if the "translation_priority" column exists. If so, you can simply close this error message that this should be working correctly.

If this message appears again, please let us know. At the moment it seems like everything is working properly.

Thank you.

May 27, 2019 at 1:04 pm #3897461

markoP-4

My issue is resolved now. Thank you!