This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:Unknown column 'translation_priority' in 'field list'

Solution:there seems to be some custom CSS controlling the switcher setting it to "display: none" , therefore hiding it.

The bellow CSS is the one controlling the switcher and hiding it, i am not sure if you added this or one of your developers, please review it and change accordingly.

.menu-item-language { display: none !important; }

removing it resolves the issue.

Relevant Documentation:

This topic contains 11 replies, has 2 voices.

Last updated by doniaB 2 months, 4 weeks ago.

Assigned support staff: Bobby.

Author Posts
June 24, 2019 at 2:41 pm #4078069

doniaB

Tell us what you are trying to do?
Nothing, we have this message when updating WPML

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?
hidden link

June 24, 2019 at 8:37 pm #4079697

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

please go to your database table icl_strings and share with me a screenshot of the structure such as the one i have shared with you.

you might be missing one of the index fields as the error is suggesting , if that is the case i will need to access the backend to re populate it for you and resolve this error.

July 1, 2019 at 2:35 pm #4120333

doniaB

Hello, please find attached our database scrennshot.
Thanks.

July 1, 2019 at 5:20 pm #4121373

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

your database table looks as expected

are you still receiving this warning ?

If yes i would like to take a closer look at the backend

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

July 2, 2019 at 6:48 pm #4129517

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

everything checks out , the warning might still have been showing due to cache.

i currently do not see the warning anymore please verify with me

July 3, 2019 at 2:35 pm #4137467

doniaB

Hello I haven't anymore the message.
I activate the menu language switcher and doesnt' appear (last menu item).

And I also activate a footer language switcher: the chinese doesnt't work (I obtain the page in French)

Thanks.

July 3, 2019 at 5:22 pm #4138379

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

it seems that Chinese is not yet translated for the homepage

what are your results after you translate the page to Chinese ?

July 5, 2019 at 4:56 pm #4152957

doniaB

hello,

I updated all chines pages but the language switcher doesn't appear on the menu 🙁

We only have the footer.

Thanks.

July 15, 2019 at 3:00 pm #4212635

doniaB

Hello, I updated the theme.
The menu switcher doesn't appear.

Could you please verify?

Donia

July 16, 2019 at 4:59 pm #4222501

doniaB

Hello, he theme updated is 2.4 and is also availble in your sand box.
Unfortunately, the switcher is not working.

Thanks for your help.

Donia

July 16, 2019 at 10:26 pm #4224273

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi Donia,

thank you for uploading the Theme on the sandbox environment

the language switcher works as expected.

On your live site there seems to be some custom CSS controlling the switcher setting it to "display: none" , therefore hiding it.

The bellow CSS is the one controlling the switcher and hiding it, i am not sure if you added this or one of your developers, please review it and change accordingly.

.menu-item-language {
display: none !important;
}

removing it resolves the issue.

July 18, 2019 at 1:47 pm #4239303

doniaB

My issue is resolved now. Thank you!