This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Raja Mohammed 6 months, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
March 18, 2019 at 7:24 pm

jeffM-17

After updating the plugin, I am trying to keep my website intact like it was.

Link to a page where the issue can be seen: hidden link

I expected to see:
The same website with the same functionnalities. The translations that were registrered.

Instead, I got:
- My custom emails sent by people asking for quotes when they "buy" a product on woocommerce are missing fields and not translated.
- The reason I have updated the WPML plugin is to avoid these problems with the error message.

Please do not make any change before contacting at first with me.

March 19, 2019 at 9:05 am #3376739

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Welcome to our forum,

It may be happening because of the _icl_strings table missing the translation_priority column, There are various reasons for this to happen. However, we can fix this with simple steps

Please try the following steps after a site back up and make sure the issue is existing or not.

1) Login to MySQL via PHPMyAdmin or similar tool
2) Choose your database
3) Run the following query. Please note your table prefix may be different(wp_icl_strings)

ALTER TABLE wp_icl_strings ADD COLUMN translation_priority varchar(160) NOT NULL;

Please, Let me know the results. If you need further assistance I will be happy to help you.

Kind regards
Raja

March 19, 2019 at 9:13 am #3376863

jeffM-17

SQL query:

ALTER TABLE wp_icl_strings ADD COLUMN translation_priority varchar(160) NOT NULL

MySQL said:

#1060 - Duplicate column name 'translation_priority'

March 19, 2019 at 11:33 am #3378519

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for the update,

Maybe this is a problem with your site's cache and so the message still appears, even though the column already exists. I think you are using WPRocket try flushing the cache, Also if your server has some caching mechanism try disabling it?.

If the problem persists, please as a test, could you disable all non-WPML plugins, switch to the default theme and see if the problem persists?

If the problem is fixed, please, enable the plugins one by one to see if there is any compatibility problem between these plugins.

If the problem still persists, let me know I will check this further in my local environment.

Please let me know the results.

Kind regards
Raja

March 20, 2019 at 8:38 am #3386133

jeffM-17

the problem still persists, wether I disable plugins with health check plugin, desactivate them, change the theme.. Maybe I did something wrong, the website itself hasnt been created by me, and isnt that great at all. but the plugin worked perfectly before the update.. and my custom emails were sent in english and french depending of the language of the session 🙁

March 20, 2019 at 12:41 pm #3388333

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the update, I will check this in my local setup with your duplicator backup,

In the meantime, please try reinstalling WPML, You can download a fresh copy from your wpml account https://wpml.org/account/downloads/. This might help in some cases.

Recomended : backup your site and database

Steps to reinstall:
- Deactivate the existing WPML plugin and add-ons.
- Delete the plugin files – this does not delete your translations. You will just delete the plugin files from your "wp-content/plugins" folder, all your data will be kept saved.
- Install and activate a fresh copy downloaded from you WPML account https://wpml.org/account/downloads/.

let me know if this helps.

Regards
Raja

March 22, 2019 at 8:51 pm #3444225

jeffM-17

hey, looking forward some news from your side. here is what i got when i tried to re-install the wordpress website in my local files, hope this helps:

March 22, 2019 at 9:06 pm #3444273

jeffM-17

Can't really do it on a staging site or local since it does not work properly. Please, directly access to the online website to see what is so wrong about the current WMPL plugins. I will try in the night of monday ET to do these procedures, but I am pretty sure there are other ways of fixing this problem. I would definitely enjoy to have this problem fixed, since this is my first experience with the WPML support. Thank you!

March 25, 2019 at 12:58 pm #3453679

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for your patience

I have requested my colleagues from the second tier for their advice. I will update you soon once i hear from them.

Kind regards
Raja

March 26, 2019 at 4:01 am #3459109

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I got an update from our second-tier supporter please follow the below steps

1) login to your database using PHPMyAdmin or ARI Adminer plugin
2) In wp_opitons table search for the option_name wpml_notices and icl_admin_messages
3) Delete both the options from the table
4) Reactivate WPML plugin

Let me know if you can handle this. if not I can help you fix the issue.

I hope this solves your issue, tested on your duplicator package.

Kind regards
Raja