We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by ilanaG 4 months, 1 week ago.

Assigned support staff: Lauren.

Author Posts
June 6, 2019 at 5:56 pm

ilanaG

I am trying to: Remove all of these Database Errors. Also, I want to edit "Strings from all text domains will be auto-registered" but when I hit "Apply" nothing happens and I think it may be related to this error.

Link to a page where the issue can be seen:
hidden link

I expected to see:
Not all of the pHP errors

Instead, I got:

June 6, 2019 at 7:31 pm
June 6, 2019 at 7:32 pm #3971769

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

June 6, 2019 at 7:44 pm
June 7, 2019 at 6:06 pm #3978303

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I've tried installing the files but the database import is failing. Could you please try using the All In One Migration plugin? I have marked the next file as private so you can share a link to download the file once it is ready.

June 10, 2019 at 7:28 am #3985569

ilanaG

Exporting the site via All-in-One isn't working.

By the way, I set WP_DEBUG to 'false' for now so the error messages aren't showing. If you need me to change it back to true, please let me know.

June 10, 2019 at 7:36 am #3985657

ilanaG

and yes, I did try again

June 10, 2019 at 1:59 pm #3987859

ilanaG

OK, I managed. I realized what was causing that problem. I have downloaded a .wpress file. How can I get that to you?

June 10, 2019 at 4:56 pm #3988943

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Excellent! You can upload the file to Google Drive or Dropbox, and share the link in the next reply. I have marked it as private.

June 11, 2019 at 1:58 am
June 12, 2019 at 6:12 pm #4006913

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thanks for sending the files. It took me a bit to set up your site, but once I did, I was able to resolve the error by following these steps:

1. Switch to a default theme and deactivate all non WPML Plugins
2. Access the database and look in the icl_string_translations table. There were two missing columns, for translation_service and for batch_id. I added both columns without any problem, and followed the settings attached in the screenshot.
3. I went to change the auto register strings and was able to save the changes. No more errors appear in the debug log.

Please try these steps on your live site and let me know if it resolves the issue.

July 7, 2019 at 6:26 am #4157235

ilanaG

We decided instead to ditch WPML altogether because it was running an incredible number of queries on the site and contributing to a significant increase in page load times. As soon as we disabled the WPML plugins we got an email about a new version of String Translation that seeks to mitigate this issue, but I guess this time it is too late. Thanks anyways.