Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 10 replies, has 2 voices.

Last updated by Bigul 1 month, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
October 9, 2019 at 12:07 pm #4722539

sarahE-4

when editing menus, unrelated translated menus become damaged/corrupt and this is happening frequently.

Translated menus are becoming sporadically corrupt.
Currently you may see an example of this with the footer. it has 4 widgets labeled footer column 1 through footer column 4. The english version is proper, the translated version is displayed improperly.

October 9, 2019 at 12:30 pm #4722795

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve this issue.

Now the Footer Column widgets have not selected the menus yet. Please check the attached images.

So please choose the relevant menus once again and save the widgets. Then make sure the issue is existing or not.

--
Thanks!

Bigul

October 9, 2019 at 2:16 pm #4723681

sarahE-4

The issue remains. Widgets have been updated to select the correct nav menu item. The 4 columns of nav menus in the footer appear mal-formatted in the french version

You don't need debug info, you already have admin access to the test copy of the site.

October 9, 2019 at 6:23 pm #4725131

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I would like to try a few troubleshooting steps on the site after making a Duplicator copy of the site(using the Duplicator plugin). Hope it will be okay.

--
Thanks!

Bigul

October 13, 2019 at 1:35 am #4743381

sarahE-4

Any progress?

October 14, 2019 at 8:31 am #4748051

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Sorry, I was waiting for your permission(as per our policies) to make a copy of your site using Duplicator plugin for further debugging. Because it looks like a compatibility issue. Please let me know your feedback.

--
Thanks!

Bigul

October 15, 2019 at 12:22 am #4753205

sarahE-4

Yes, you may make a copy

October 15, 2019 at 11:37 am #4756667

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. I made a Duplicator copy of the site and debugging the issue now. Will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

October 18, 2019 at 4:32 pm #4784619

sarahE-4

?

October 21, 2019 at 6:00 am #4791223

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, the bug is existing after the primary debugging procedures and not able to reproduce the issue in a fresh installation. Therefore I have escalated the ticket to our second-tier team for further debugging.

Please wait. We will get back to you as early as possible.

--
Thanks!

Bigul

October 22, 2019 at 6:17 am #4798945

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind information, the issue is happening because of the usage of

<strong>

tags to some items of the menu. There are two workarounds to fix this issue.

a) Open the footer.php file(wp-content/themes/bridge/footer.php) of the Bridge theme and replace the following snippet(lines 217-238). We are just removing the blank spaces/line breaks between one column to another.

From

<div class="four_columns clearfix">
	<div class="column1 footer_col1">
		<div class="column_inner">
			<?php dynamic_sidebar( 'footer_column_1' ); ?>
		</div>
	</div>
	<div class="column2 footer_col2">
		<div class="column_inner">
			<?php dynamic_sidebar( 'footer_column_2' ); ?>
		</div>
	</div>
	<div class="column3 footer_col3">
		<div class="column_inner">
			<?php dynamic_sidebar( 'footer_column_3' ); ?>
		</div>
	</div>
	<div class="column4 footer_col4">
		<div class="column_inner">
			<?php dynamic_sidebar( 'footer_column_4' ); ?>
		</div>
	</div>
</div>

To

<div class="four_columns clearfix">
	<div class="column1 footer_col1">
		<div class="column_inner">
			<?php dynamic_sidebar( 'footer_column_1' ); ?>
		</div>
	</div><div class="column2 footer_col2">
		<div class="column_inner">
			<?php dynamic_sidebar( 'footer_column_2' ); ?>
		</div>
	</div><div class="column3 footer_col3">
		<div class="column_inner">
			<?php dynamic_sidebar( 'footer_column_3' ); ?>
		</div>
	</div><div class="column4 footer_col4">
		<div class="column_inner">
			<?php dynamic_sidebar( 'footer_column_4' ); ?>
		</div>
	</div>
</div>

b) Remove the

<strong>

tags from the menu(remove also from the menu translations). Then use CSS instead of it.

Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul