Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 23 replies, has 2 voices.

Last updated by Bigul 4 months ago.

Assigned support staff: Bigul.

Author Posts
March 6, 2019 at 11:57 am #3278684

julianZ-4

I am trying to: https://wpml.org/forums/topic/custom-taxonomy-duplicate-content-problem-with-hreflang-canonical/

Still unresolved after more than 4.5 months. This is really hurting my SEO. And I'm writing in this thread with "I still need assistance" several times. Did not hear back from your team.

I had to create so many tickets for bugs, I feel like a beta-tester. Always when I try to change a setting or do something with WPML, it doesn't work.

Please conntect me with a manager. This is really unacceptable. Please have a look at my support tickets.

March 8, 2019 at 6:14 am #3289486

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Really sorry for the troubles. I apologize for the delay. The previous ticket is currently assigned to another supporter. He is on vacation and only back on Monday.

This bug is expected to fix in the current version of WPML(4.2.4 series). Therefore please upgrade to the latest version of WPML plugins after a full site backup and check the bug is existing or not.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

March 8, 2019 at 12:39 pm #3292194

julianZ-4

Hello Bigul

Thanks for your feedback. I just did the update to the newest version (4.2.4.1)

The bug is persistent, unfortunately.

There are some URLs, that are fixed with the update.

Working: hidden link => creating redirect to the correct URL hidden link

Still not working and creating duplicate content:
hidden link => it's the same format as the URL above. This one just shows the French version. But the URL does not include the folder /fr/ as it should. DC is under hidden link
hidden link => DC: hidden link & hidden link (Should be original URL)
hidden link => Original URL should be: hidden link as it's the german version

I have many more examples but took these out of my .htaccess, where I manually created the redirects for these URLs so you can check for yourself.

How to proceed?

It's really a BIG problem for me because Google sees thin content. This really messed with my Search visibilty and cost me a lot of money last year.

March 8, 2019 at 3:30 pm #3293734

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

March 8, 2019 at 3:36 pm #3293810

julianZ-4

Hello Bigul

What do you want to check exactly? Could you only do a duplicator copy and leave the rest? As it's a live site, I'm worried to give access.

March 12, 2019 at 10:31 am #3321015

julianZ-4

Hi Bigul

I tried to do the migration, but there is no field to input database username and password: hidden link

I tried anyway to do the migration. I got a success notice, but the URL still looks the same. Seems that Cloudways was not able to migrate the database.

Furthermore, please mark my next answer as private so I can provide you with login credentials.

March 12, 2019 at 5:34 pm #3327101

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Migration was successful. Please check the attached image.

I am enabling private information for the next reply. Please share me the admin credentials.

--
Thanks!

Bigul

2019-03-12_2303.png
March 13, 2019 at 7:44 am #3330301

julianZ-4

Hi Bigul

Okay, I did not see that 🙂 But good, that it worked

Here are the login details for the test system:

Ooops.. somehow this was not sent via secure form... can you plase activate this field again?

Best regards

Julian

March 13, 2019 at 4:39 pm #3336367

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Julian,

Thank you for the updates. I am enabling private information for the next reply. Please check and share the admin credentials.

--
Thanks!

Bigul

March 14, 2019 at 5:31 pm #3347449

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Julian,

Thank you for the updates. I am continuing the testing on this and would like to try with the latest version of the theme. Because as per our support policies we have to make sure the issue is existing with the latest version of plugins/theme.

So can you please upload the latest version of the parent and child theme on the test site.

--
Thanks!

Bigul

March 14, 2019 at 6:00 pm #3347763

julianZ-4

Hi Bigul

I just needed to activate the theme and click on "update". It's done now, it's on the latest version. You can try again. If you want to investigate further, you can also update all plugins and wordpress, there should be no incompatibilities.

I'm also a bit worried: It took my robots.txt and I also could not find any noindex tag on the cloudway domain.

March 14, 2019 at 7:17 pm #3348125

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Julian,

Thank you for the updates. I would like to know more about the following. Please share more details about your noindex tags.

It took my robots.txt and I also could not find any noindex tag on the cloudway domain.

Also please share the *robots.txt* file via Google Drive. I am enabling the private option for the next reply.

--
Thanks!

Bigul

March 15, 2019 at 7:05 am #3351627

julianZ-4

Hello Bigul

It's just that I'm worried, that Google could index the test system we just created on cloudways because cloudways did not set any noindex tags and it also did not block search engine robots via robots.txt.

You can just continue as normal, IF cloudways secures with any other means that Google does not index the test system.

March 16, 2019 at 7:57 am #3359193

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Julian,

I have done a few rounds of testing on the test site. The issue is existing with the Audible and Booking terms after the initial debugging steps. Therefore I will check about it with our second tier team and get back to you.

In the case of UPC term, it was not properly translated. It was showing as a separate term in French. It works after I set the French term as the translation of German UPC term. Please visit the following link and it will redirect us to the correct URL. Check the attached images for more details and let me know your feedback.

hidden link

--
Thanks!

Bigul

2019-03-16_1244.png
2019-03-16_1243.png
2019-03-16_1242.png
March 16, 2019 at 3:54 pm #3360893

julianZ-4

Hi Bigul

Thanks for your reply.

It's possible, that UPC is a fault on our side.

If you want to have more examples to investigate this bug further, you can just have a look at the .htaccess -> I manually added many redirects of sites that are indexed twice in the .htaccess.

I hope the second tier support can fix this bug, soon.

The topic ‘[Closed] Unresolved ticket for more than 4 months’ is closed to new replies.