This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Carlos Rojas 3 weeks, 6 days ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 16, 2019 at 11:20 pm

anthonyL-13

I am trying to: unsafe scripts warning

Link to a page where the issue can be seen:hidden link

I expected to see:

Instead, I got:
Ever since I installed WPML, I have been getting unsafe scripts warnings. For example, warnings like "parts of the page are insecure, such as images.

September 17, 2019 at 3:55 pm #4589899

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

It seems there is a compatibility issue between some functionalities in the site. I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush all cache memory.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Kind regards,
Carlos

September 20, 2019 at 12:41 am #4608533

anthonyL-13

I have found that if I disable the security plugin, the issue seems to go away.

I have tried different ones and they all had the same problem. They give a warning about unsafe scripts with images as an example.

I really want to have some kind of a security plugin.

September 20, 2019 at 10:14 am #4611325

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

Could you provide the name of the security plugin?

Regards,
Carlos

September 20, 2019 at 12:18 pm #4612005

anthonyL-13

MalCare WordPress Security, Firewall & Malware Scanner
and
All In One WP Security

September 20, 2019 at 12:26 pm #4612029

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I kindly ask you to visit this link where you will find the Multilingual-Ready Plugins list validated by our compatibility team: https://wpml.org/documentation/plugins-compatibility/

There you will find all plugins validated by our compatibility team as compatible with WPML.

Regards,
Carlos