This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 29 replies, has 2 voices.

Last updated by Alejandro 4 months ago.

Assigned support staff: Alejandro.

Author Posts
May 26, 2019 at 6:17 pm

alpine-airlinesS

I'm hardly struggling to make WPML work.

The website is online but on a development address, and I consequently prefer not to give the address unless you can assure me it won't be publicly displayed in the support forum.

I have various issues:
- On the welcome page, translation is supposed to exist (displayable in the advanced editor, looks OK in the pages list, but displays "nothing found" on frontend)
- On another page ("Courchevel"), all looks OK (again, in pages list and in advanced editor) but English-translated page on website displays a copy of the French version (default langage)
- On another third page ("Notre Flotte"), when I try to add translation (clicking "+"), I got to the advanced editor, then when finished I go back to the pages list, but it seems that the translation is not recorded (no new page in English, and icon in page list is still "+" not the little pen). However, when I click "+" again, my translations in the advanced editor are still here

History:
- I developped my site in local and moved it online (copied files via FTP, copied database, and modified database addresses with srdb
- It was buggy at first, but only in the advanced editor. I removed and reinstalled WPML on the online version and now have the above described issues.

May 27, 2019 at 8:40 am #3894759

alpine-airlinesS

Any feedback?

May 27, 2019 at 8:56 am #3894925

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

To continue, I'll need temporary access to your site.

I have just activated the appropriate boxes for the credential information i need from you. they are private so only you and i will be able to see them (so i confirm everything will be set as private).

All the links that you share in here will also be hidden to users apart from the both of us, so you don't have to worry about that, either.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the fields mentioned above.

May 27, 2019 at 10:35 am
May 27, 2019 at 12:59 pm #3897367

alpine-airlinesS

Any feedback? This problem is beginning to become urgent...

May 27, 2019 at 3:16 pm #3899019

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,
I made a few tests and indeed the page seems to just be copying everything from the original language without even translating it.

Can you please ask your hosting company if they have any kind of caching enabled? all the issues that we've had that have been similar to yours have turned out to be caching issues (server-side, caching issues). Most of them were caused by "memcached" enabled on their installations. If you have access to the options of your PHP Version, then try disabling it (memcached) and ask your hosting about cache flushing, so you can check the live version of your site. you can also ask your hosting company to do that for you.

If you want, you can also migrate your site to one of your staging environments so we can test if the problem is present there as well (that way we could also rule out a caching issue, id it turns out that isn't the case).

If you want to proceed with that test, then you will find a private answer(my next reply) with all the instructions and information needed in order to proceed.

Regards.

May 27, 2019 at 3:20 pm
May 27, 2019 at 4:19 pm #3899581

alpine-airlinesS

I tried to install extension that "Purge caches" (W3TC) but I don't know if it can do what you required. I'm still looking on hosting side.

I migrated the site, you can dive into it and have any tries!!
Waiting for your feedback

May 28, 2019 at 7:15 am #3903325

alpine-airlinesS

Still need assistance on this topic! Thank you Alejandro

May 28, 2019 at 9:00 am #3904425

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Can you try accessing with your own credentials to the migration site and try to translate a page?

I updated the pages that had issues by just adding a character to the title and then updated the translations as well (through the translation editor) and everything seems fine, it got updated without issues.

i then translated a new page: hidden link

and as you can see (check the "+" characters on the title) it's updated as well, so i think it is a problem with caching. but you do need to update the translations in order for them so start showing correctly.

May 28, 2019 at 7:04 pm #3909655

alpine-airlinesS

Indeed it looks like it's working on Cloudways.
On Cloudways, I still have 2 minor problems:
- When I tried to add a translation of "Bases", it opens a pre-filled standard WPML translation interface (instead of advanced translation manager), I don't understand why
- On other pages that have a working translation, when I finish a translation, I sometimes (randomly) have the following: instead of going back to pages list, I go back to a backoffice error message saying "this user is not authorized for this translation" (with translation being nevertheless correctly saved)

But this is not the most important to me.

The most important is that it's still not working on my server.
On my server, I tried several things and have the following behaviour:
- On backoffice, all looks great: translated pages have the little pen icon, when I click it, I retrieve my translations.
- But on the website side, english pages are still a pure copy of the French pages, except the titles of the pages (displayed at the top of the page) which is indeed translated (=corresponding to the english title of the created page)
- I noticed that when I update a translation and refresh IMMEDIATELY the page on frontend, I do have the correct English translation!! But when I refresh again let's say 10s after, it's back in French.

If it's a server option, can you explain me how to set it correctly? I looked for any information about memcached on my server interface but I have nothing mentionning it. (I'm hosted by OVH)

As I mentioned on my first post, the site was migrated from local to the OVH hosted ftp, and then database was modified with SRDB. Could it possibly be the cause of the problem?

And in our debug process, could it be a problem to have 2 sites with identical pages names on the same WPML login? Because if I understand well, the advanced editor takes the content of my website to my WPML account, allow to edit in the advanced interface, then send it back to my backoffice... Am I right?

May 29, 2019 at 7:09 am #3912269

alpine-airlinesS

It's very surprising because all the other features of my other plugins are working perfectly, I only have problems with WPML...

May 29, 2019 at 4:35 pm #3917419

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Let me try to answer all your questions:

You said:
"- When I tried to add a translation of "Bases", it opens a pre-filled standard WPML translation interface (instead of advanced translation manager), I don't understand why"

Answer: Yes, that's actually normal, because we migrated the site but there's an "authorization code" if you will, which is not the one from your installation, but that can be easily fixed if you want to see it working, just let me know

You said:
"- On other pages that have a working translation, when I finish a translation, I sometimes (randomly) have the following: instead of going back to pages list, I go back to a backoffice error message saying "this user is not authorized for this translation" (with translation being nevertheless correctly saved)"

Answer: That usually happens because the user who tried that has either an editor role or it's not set as a translator for the pair in question, in WPML > Translation management > Translation roles

You said:

"- On backoffice, all looks great: translated pages have the little pen icon, when I click it, I retrieve my translations.
- But on the website side, english pages are still a pure copy of the French pages, except the titles of the pages (displayed at the top of the page) which is indeed translated (=corresponding to the english title of the created page)"

Answer: Yes, and i believe the problem there is a cache issue but not on your site, on your server. it' either that or a database issue. there's something that is sort of copying the original translation (which is a normal procedure) but then it's just not continuing (i.e: sending over the translated content).

Please ask your hosting company is a caching system is enabled on the server (such as memcached, varnish, redis, opcache, etc) and if it is, disable it for the time being and flush the server's cache (the hosting company needs to handle that part).
That way i can check again and rule out caching as the issue. we know it works and the only different is the server so it must be a server setting or something else in the server environment.

By the way, i don't think you can set that yourself, you have to ask customer support because it could be accessed by them alone so you might not even see it on your installation.

You said:
"And in our debug process, could it be a problem to have 2 sites with identical pages names on the same WPML login? Because if I understand well, the advanced editor takes the content of my website to my WPML account, allow to edit in the advanced interface, then send it back to my backoffice... Am I right?"

Answer:
it's not a problem, really. the content is still and will always be on your server. what is sent to our servers is just information that is private to each site, so if the pages are identical but on 2 different domains, then the pages will be treated as individual pages, they will definitely not communicate between them or have any reference to each other whatsoever.

May 30, 2019 at 9:29 am #3921727

alpine-airlinesS

Dear Alejandro,

Thank you for your time investigating and your long answer.
I found how to deactivate the cache on the server, unfortunately it did not solve the problem, English pages are still in French. (note that I had to enable back the cache after testing, since this server is also hosting the current production website)

Note that the previously decribed behaviour (in which the English page appeared in case of refresh just after having updated translation, reverting back to French at next refresh) no longer appears with cache off.

You suggested a database problem, but in this case how can we explain that it's working on the Cloudways copy?...

I'm running out of new ideas, your feedback would be greatly appreciated again!

May 30, 2019 at 3:09 pm #3924099

alpine-airlinesS

I also note that when de-activating totally WPML translators (either advanced or legacy) the website works...
The problem in this case is that I miss all the advantages of WPML translators!

The topic ‘[Closed] Unsolvable installation problem’ is closed to new replies.