This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.54 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: No logro traducir algunos elementos de mi menú traducido

Solution: Por favor sigue la guía del link de abajo y asegurate de limpiar el cache al momento de revisar el resultado

Relevant Documentation: https://wpml.org/documentation/getting-started-guide/translating-menus/

This topic contains 8 replies, has 2 voices.

Last updated by paulaD-8 2 months, 3 weeks ago.

Assigned support staff: Alejandro.

Author Posts
July 19, 2019 at 6:29 am #4244193

paulaD-8

Hi!

I've been trying to solve this by researching, but I can't seem to get to a solution. And I'm afraid I'll mess something up. So I need your help 🙂

I am trying to sync the Recipe categories on the main menu. Here is a link to a page where the issue can be seen: hidden link

I expected to see the translated Cakes page (Tortas). Instead, it keeps redirecting me to the English version.

The other pages on the menu are perfectly synced. Meaning, if I go to Contact page, and click Español in the menu, it takes me directly to Contacto (its translation). I want the same for the Recipe categories.

I hope I'm clear enough to get some help.

Cheers,

Paula

July 19, 2019 at 7:08 am #4244377

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

It all depends on how the menu is made. i checked your site and it looks as if all the items from that menu elements (including the dropdown menu elements) are all in English.

Can you confirm they are category elements and not custom links with the category elements?

One interesting fact that i saw is that even though the link to the category seems to be showing alright in the language switcher (i tested it in the cakes category), there seems to exist a redirection to the English page So to better understand how to move forward with a solution, could you please provide me with information about your environment by following these steps: http://wpml.org/faq/provide-debug-information-faster-support/

I'll study it and check how should we proceed.

July 20, 2019 at 5:30 pm #4250361

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Thanks for that.

Let's start by meeting WPML's minimum requirements:

Please add the following code in your wp-config.php file, right after the database information lines of code:

define('WP_MEMORY_LIMIT','128M');

This is actually a safety step, because it might affect what you need to do now which is:

- Go to WPML > Taxonomy translation
- Select "categories" from the dropdown menu (it might not be called "categories" if these categories are not the posts categories. in that case select the right option)
- Translate your categories
- I see that you seem to have subcategories (Argentinean scones, etct) so translate them as well.
- Go to WPML > Menu Synchronization and sync the menus.

In short, the categories don't seem to be translated so you need to translate them and then synchronize the menu.

You can find more information about category translation in here: https://wpml.org/documentation/getting-started-guide/translating-post-categories-and-custom-taxonomies/

Let me know how it goes.

July 21, 2019 at 2:08 am #4250713

paulaD-8

Hi,

So I tried adding that line of code to WP-config.php and it didn't work. I would make my site unavailable. I must be doing something incorrectly, so I attach a screengrab (1) to help you see what I did.

For what I see, the categories are in fact translated, unless I did something wrong there too. I attach another screenshot (2) to show what I think refers to them being translated.
When having done this again, just in case, I go to syncronize menu, and it duplicates the categories in the menu (3), which lead to a 404 error page (4). Now it's not even redirecting me to the English version of the category.

I hope there is something else I can try.

Cheers,

Paula

July 22, 2019 at 6:13 am #4254129

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

It broke your site because of a "copy-paste" issue.

As you can see from the screenshot, the code you pasted is not the same as the one i wrote. basically, all the "special characters" were pasted in their encoded version.

However, i'd like to take a closer look at this problem if it's not a problem for you.

I have just activated the appropriate boxes for the credential information i would like to have in order to access your site. They are private so only you and i will be able to see them.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the fields mentioned above.

After looking at the problem, i'll be able to better help you out.

July 25, 2019 at 11:00 am #4282101

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi,

The menu is fixed.

In order to make it work, i had to increase the memory as mentioned above and then i had to delete the spanish menu because it seemed it had been manually added so i basically duplicated every element that was manually added.

then i re-synched the menu and now it seems to be working correctly everywhere.

I followed the steps in here: https://wpml.org/documentation/getting-started-guide/translating-menus/

Regards.

July 25, 2019 at 12:29 pm #4283063

paulaD-8

Hi Alejandro,
Thanks for taking the time to see this. I checked in Chrome and Safari, and the menu looks good in Spanish, but when I click in each category (Torta, Galletitas, etc.), it keeps sending me to an error 404 page, in the website in English.
Is there a phone number I can call, maybe at a time convenient for both? So we can sort this soon? And avoid another day of coming and going?
Thanks a lot again!

July 25, 2019 at 2:16 pm #4284093

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

The problem was

1) cache (i didn't realize you had a cache plugin active and didn't flush the cache
2) Your category slug was "Categoria" with a capital C, and that's not allowed. i removed it and it seems to work now.

Can you check and let me know if everything's alright now?

July 25, 2019 at 10:10 pm #4286173

paulaD-8

My issue is resolved now. Thanks so much, Alejandro!