This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to translate the button link url on a slide in a fullwidth slider in Divi.

Solution: Go to WPML -> Settings -> Custom XML Configuration -> Add the following code:

<wpml-config>
<shortcodes>
  <shortcode>
    <tag>et_pb_slide</tag>
    <attributes>
      <attribute>heading</attribute>
                <attribute>button_text</attribute>
                <attribute type="link">button_link</attribute>
                <attribute>background_image</attribute>
    </attributes>
  </shortcode>
</shortcodes>
</wpml-config>

Relevant Documentation: https://wpml.org/documentation/support/language-configuration-files/

Author Posts
October 15, 2018 at 11:59 am #2817241

bennyG

I am trying to: translate the button link url on a slide in a fullwidth slider in Divi.

Link to a page where the issue can be seen: hidden link -> The orange Demander Un Devis button points to the English page. Other links on the page (in different Divi modules/blocks are translated ok).

I expected to see: A link pointing to hidden link

Instead, I got: A link pointing to hidden link

I'm using the new Advanced Translation Editor.

I tried the following, but nothing worked:
- Switching to the manual translation editor
- Installing Sticky Links
- Adding a button_link attribute in my wpml-config.xml file in my Divi theme:
<shortcode>
<tag>et_pb_slide</tag>
<attributes>
<attribute>heading</attribute>
<attribute>image_alt</attribute>
<attribute>button_text</attribute>
<attribute>button_link</attribute>
</attributes>
</shortcode>
- Resaving the English page and then the translations doesn't help either.

October 16, 2018 at 9:42 pm #2822461

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.
I will do my best to help you solve this issue.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Kind regards,
Carlos

October 17, 2018 at 2:45 am #2822953

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Benny,
Thank you very much for the information provided.

I added the XML code to WPML -> Settings -> Custom XML Configuration. Also, I added the full URL to the link destination.

Could you double check if the issue persists?

Best regards,
Carlos

October 17, 2018 at 6:38 am #2823236

bennyG

Yes, the problem is still there. The URL field is not visible in the list of fields in the ATE. I also tried resaving the English page first, but no help.

October 17, 2018 at 7:39 am #2823525

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Benny,
Thank you very much for your feedback.

When I try to translate the Home page from English to French I get the Classic Translation Editor. In this interface the URL field is shown correctly (see attached image).

I kindly ask you to follow this steps:
- Go to WPML -> Settings -> How to translate posts and pages -> Click on 'Synchronize translators and translation managers' button
- Update Divi theme to the latest version.
- Flush any cache memory that migh exists.

Could you tell me if the issue persists?

Best regards,
Carlos

October 17, 2018 at 8:24 am #2823752

bennyG

I did those 3 steps and it's still not showing. I do see it in the Classic Translation Editor now, but not in the Advanced one.

October 17, 2018 at 7:16 pm #2825730

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Benny,

Could you tell me if the issue persist after following this steps:
- Finish the translation in the Advance Translation Editor (100%) -> Make a small change to the button element in the original language -> Send the page again to translate with ATE.

Does the Advance Translation Editor recognize the element this time?

Best regards,
Carlos

October 17, 2018 at 7:28 pm #2825745

bennyG

No luck unfortunately 🙁 It did recognize the new button text, but the URL is still not translatable.

October 18, 2018 at 1:17 am #2826115

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
I'm sorry for the late reply.

I created a fresh new install and I was able to reproduce the issue. I have escalated this ticket to our commpatibility team where our compatibility specialists will take a deeper look at the issue and will try to find a solution.

I will get back to you as soon as I have an answer.

Thank you very much for your understanding!
Best regards,
Carlos

October 22, 2018 at 10:42 pm #2840004

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Benny,

I followed this steps:
- I added a small change to the XML code in WPML -> Settings -> Custom XML Configuration.
- Re-traslated the 'request a quote' page to all languages (you might need to take a look at this translations because some of the content is still in English).
- Edited the homepage in English -> Made a small change in the slider element -> Saved the page and updated the translations.

Now you can see that the issue is solved. Could you confirm it?

Note: I tested this with the Classic Translation Editor because my user doesn't have the permissions to use the Advance Translation Editor, however it should work correctly. Also, there is important to notice that if the URLs are internal then they will be automatically translated and won't show up in the translation editor, if the URLs are external (for example: hidden link) then they will appear in the editor.

Looking forward to your answer.
Best regards,
Carlos

October 22, 2018 at 10:51 pm #2840007

bennyG

My issue is resolved now. Thank you!

October 22, 2018 at 11:20 pm #2840031

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Benny,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos