Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Itamar 6 months, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
May 4, 2019 at 3:30 pm #3740593

robertL-38

Untranslated pages are not pointing to the default language page. See enclosed (image named ... 27 - French - not showing the content you see on ... 28)

May 5, 2019 at 5:21 pm #3743577

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

I can see the problem on your site here.
hidden link
This is happening because none of your 'Team' items are translated. For example this.
hidden link
You should either translated them or if they are a custom post type set them to 'Translatable - use translation if available or fallback to default language' in WPML -> Settings -> Post Type Translation. Then I hope that they will show on your untranslated pages.

Please let me know if it is working for you.

Regards,
Itamar.

May 8, 2019 at 5:31 am #3763911

robertL-38

I thought I had set it to fallback to default language. See screenshot.

May 9, 2019 at 6:52 pm #3778905

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi,

From your screenshot, I can see that 'Pages' and 'Posts' are set to 'Translatable - use translation if available or fallback to default language'. All the rest of the custom post types (CPT) are not set to this option. But maybe I do not see all the CPTs. I was expecting to see 'Team' CPT, but I do not see it.
Is each team member a regular post?
Can you please try to translate one of the team posts into French and see if then it shows on the French page?
hidden link

If it doesn't work, then please let me have access to your site so I can check things.
If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

The topic ‘[Closed] Untranslated pages are not pointing to the default language page’ is closed to new replies.