This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by majidk-3 1 year ago.

Assigned support staff: Mihai Apetrei.

Author Posts
October 4, 2018 at 9:24 am #2786922

majidk-3

Hi,
I created two different page in two different language. and also I'm using WPML in different domains. I create hidden link for English about page and create hidden link for Swedish about page. I know both of pages are created correctly.
now I can't access to English about page. It's automatically redirected to Swedish about page.
I don't use any redirect plugin and there is no redirect in .htaccess file. And Swedish page is correctly connect to English page.
Pls help me. Thanks!

October 4, 2018 at 9:30 am #2786942

majidk-3

I have same problem in contact page. hidden link is redirected to hidden link .Both page are created correctly and connected to each other with WPML.

October 4, 2018 at 9:46 am #2787072

majidk-3

oh ...!
I'm using woocomerce in my site and I created two page in two language for products page. I don't have any element in these pages. So I can't change any things. And in widgets I check sidebar to uses for both language. but sidebar doesn't show in Swedish site.
If I have to create a new support ticket for this problem, I do it.
Thanks

October 4, 2018 at 4:33 pm #2788210

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

This is an issue that we really can't guess on (especially if you say that there are no redirects set up by you) and in order to debug the problem, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved, I will delete the local site.

I will need your written approval to be able to test your site on a local environment so can you please let me know if this is ok with you?

** IMPORTANT **

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields, this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this:
hidden link

October 8, 2018 at 6:24 am #2794814

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

After taking some time to analyze your site, I can see that there are a few redirects recorded here, under the Yoast redirects settings:
hidden link (log in first in order to see them)

There's also a lot of caching happening on your site so we need to test with that disabled, too.

I will write below a few steps that I will need you to follow and let's see if any of these ones will solve the issue.

❌ First of all, please be sure to make a full backup of your site and database. ❌

STEP 1

Delete Autoptimize cache and disable the plugin. Retest.

STEP 2

Leave the Autoptimize plugin disabled. Delete SuperCache cache and disable the plugin. Retest.

STEP 3

Leave the Autoptimize and the SuperCache plugins disabled. Remove all the redirects from the Yoast ("SEO" tab) > "Redirects" tab. Retest.

Let me know how it goes and if any of these steps solved your issue.

October 8, 2018 at 6:22 pm #2797087

majidk-3

Hi.
Thanks for your reply.
I disable these two plugin and after that I saw in SEO tab in yoast that both of the page ( about and contact pages) were redirected (301) to the Swedish translation. So I delete them and retest. Contact page now works true but still About page is redirected to the Swedish translation of about page.

Thank you a lot and definitely WPML support is the best.

Pls help me to create sidebar of shop in Swedish site like shop in English site. I don't know what I have to do.

October 10, 2018 at 8:55 am #2803495

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi!

For me, the "About" page works perfectly and I could not find any redirects happening.

Is this still happening to you, too?

Can you please try from an incognito window and let me know if this still happens for you? If yes, please also let me know the steps you are taking so that I can follow the same steps.

Regarding this "Pls help me to create sidebar of shop in Swedish site like shop in English site" may I kindly ask you to please open a new ticket for your additional question?

This will help other users with similar problems to find solutions when searching the forum.

Kind regards,

Mihai

October 10, 2018 at 10:39 am #2803870

majidk-3

My issue is resolved now. Thank you!
I think my browser was cached the page, and it works true now.