This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
I updated my wpml plugin and after that, I'm getting this warning (check attachment):
https://wpml.org/wp-content/uploads/2019/09/4505915-Screenshot_2019_09_03_at_17.39.22.png

Solution:
Please follow below steps:

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

2. Please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

This topic contains 4 replies, has 2 voices.

Last updated by igorP-11 1 month, 1 week ago.

Assigned support staff: Noman.

Author Posts
September 3, 2019 at 3:40 pm #4505915

igorP-11

Hi guys, I updated my wpml plugin and after that, I'm getting this warning (check attachment).

Are you familiar in regarding that?

Thanks,
Igor

September 3, 2019 at 3:52 pm #4506011

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please delete existing WPML plugins and install them manually and check if the issue persists. To do a manual update please follow these steps:

1. Please take your full site backup.
2. Deactivate the existing WPML plugin.
3. Delete the plugin files – this does not delete your translations. You will simply delete the plugin files from your "wp-content/plugins" folder, NOT the database records.
4. Download the updated plugins from our servers (https://wpml.org/account/downloads/) and upload them to the plugin directory.
5. Activate the WPML plugin and add-ons.

Thank you

September 3, 2019 at 4:16 pm #4506167

igorP-11

Still same.

September 4, 2019 at 6:33 am #4508467

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Could you please follow below steps and let me know how it goes?

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

2. Please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

September 4, 2019 at 8:03 am #4508899

igorP-11

My issue is resolved now. Thank you!