Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: After update a page in original language, all settings in translated page are overwritten with content from the original language.

Solution: Flush all cache memory and ask your hosting provider if there is any kind of cache in the server side that could be affecting the site. Also go to WPML -> Support -> Troubleshooting link -> Click on 'Clear the cache in WPML' button. And finally, re-save the permalink structure.

Relevant Documentation:

This topic contains 5 replies, has 2 voices.

Last updated by Carlos Rojas 1 year, 10 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
January 30, 2018 at 7:58 am

peterV-47

I am trying to:

set pages translate independently.

When i set translate independently in second language all works fine.

But when i update page in original lang, all setting in translated page is gone a page is set back to duplicate from original lang and content is overwritten by default lang.

I tried delete cookies but same result.

January 30, 2018 at 12:58 pm #1501525

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello,
Thank you for contacting WPML support.

1.- Could you tell me if the issue persists in a newly created page?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

January 30, 2018 at 1:23 pm #1501583

peterV-47

Hi i increased the memory limit in wp-config and test add new page. In new page all works fine.

It looks like that problem is only on homepage. I tried delete duplicate page and add new one without duplicate content. It looks like homepage remember settings somehow.

January 30, 2018 at 4:17 pm #1501888

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,

Maybe this issue is caused by some kind of cache issue. Please create a new homepage with a different slug and then set it as a front-page in Settings -> Reading.

Note: Try to flush all cache memory and ask your hosting provider if there is any kind of cache in the server side that could be affecting the site. I will also recommend you to go to WPML -> Support -> Troubleshooting link -> Click on 'Clear the cache in WPML' button. And finally, re-save the permalink structure.

All the steps above will help to flush the cache in the site.

Please let me know if the issue is solved after this steps.

Kind regards,
Carlos

January 31, 2018 at 5:39 am #1502355

peterV-47

Hi, i created new page and before clear wplm cache. In old page same result after clear cache in new one all works fine :). I think we are done for this time. If i have trouble with some other page, i let you know .

January 31, 2018 at 3:22 pm #1502970

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi Peter,

I'm glad to hear that this issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Kind regards,
Carlos