Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by David 5 years, 1 month ago.

Assigned support staff: Beda.

Author Posts
January 3, 2015 at 5:50 am #536511

David

I am trying to: upgrade to Woocommerce 2.2

I visited this URL: hidden link (you need to add a product to the cart and go to the checkout page to see the problem.

I expected to see: my order details (order total and shipping info) on the checkout page
Instead, I got: You get the correct information for a few seconds while the page loads and then you get "Your order [object Object] It is not reading one of the Woocommerce shortcodes.

I am running this on Wp-Engine. Strangely, this worked fine in the staging evironment but I am getting this problem in the live site. The problem goes away when I disable WPML. I have attached two pictures. The staging checkout shows what it should look like and what it looks like with wpml disabled. The live checkout shows the problem I am getting.

January 3, 2015 at 7:26 am #536521

David

Update on this problem. If you have never visited the site in Chinese, it works fine. However, once you have use the site in Chinese (or maybe visited the checkout page in Chinese) you get the problem in both Chinese and English.

Please help me.
Dave

January 4, 2015 at 2:50 pm #536760

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch ) Italian (Italiano )

Hello David

Thank you for sharing the Debug Info with me

I see you already updated to WooCommerce 2.2.10, which is the latest version of this plugin.

Please could you perform this quick steps in order to isolate the issue a little bit more:

1. Activate Theme Twenty Fifteen
2. Deactivate ALL Plugins but WPML + AddOns, WooCommerce + WooCommerce Multilingual.

Please could you then check if the issue persist?

In case it does, I will surely need to request temporary access (wp-admin and FTP) to your site
- preferably to a test site where the problem has been replicated if possible -
in order to be of better help.
You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

==> Please backup your database and website <==

Thank you

January 6, 2015 at 4:21 pm #537946

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch ) Italian (Italiano )

Hello David

I see the issue.

Are the staging and live site on the same servers with exact same settings?

Sometimes PHP versions or server installs can generate different kind of issues.

Without a login I can't look closely at the issue.

You could also provide me a sites snapshot if possible.
We usually recommend the free Plugin "Duplicator" for this porpoise.

If you already know how Duplicator works
(http://wordpress.org/plugins/duplicator/),
please skip the following steps and just send me the installer file and the zipped package you downloaded.

Duplicator instructions
hidden link
Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)
IMPORTANT: remember to create or keep an admin account for me before creating the snapshot, or I won't be able to login. You may delete the new admin account once the snapshot has been built.
I will enable your next answer as private so you can provide me the information securely.

Could you also try if the steps I mentioned in my previous post do make some changes?
==>1. Activate Theme Twenty Fifteen
2. Deactivate ALL Plugins but WPML + AddOns, WooCommerce + WooCommerce Multilingual.

Please could you then check if the issue persist?

Regarding to your 2 additional queries:
1. "I wonder if it is possible to delete the pictures I posted on the forum. I accidentally posted the copies with my username visible."
DONE

2. "Second, I have changed my email address in account settings because I don't seem to get emails from this platform at my yahoo address. Can you please make sure that my new email dave@avignonflorist.com is included in your"
This should work automatically, please let me know if you don't get any notifications form us.

Thank you

January 11, 2015 at 2:42 pm #540492

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch ) Italian (Italiano )

Hello David

I have received the data and am duplicating the site now.

I hope I can give you a useful update tomorrow Monday the 12 January.

Thank you for your patience.

January 11, 2015 at 11:10 pm #540637

David

Thanks. I look forward to hearing from you.

January 12, 2015 at 1:35 pm #541046

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch ) Italian (Italiano )

Hello David

This is just a update to inform you that I am still working on this (beneath other threads as well)

Meanwhile, I can give you a short update on the issue with email notifications:

in the profile settings you have disabled the forum notifications ( see image attached )

In order to receive notifications from the support forum the 'Receive an email for replies posted to subscribed topics.' option, available in the user profile needs to be selected.

So far, I think if you enable this you should receive the notifications.

I will update you here as soon as I have more info on the "real" issue of this thread 🙂

Thank you for your patience.

January 12, 2015 at 6:25 pm #541290

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch ) Italian (Italiano )

Hello David

Here is the result of my tests:

On my localhost I have run your duplicator package that you provided.

I have:
1. Disabled ALL Plugins but WPML, WooCommerce + WooCommerce Multilingual
2. Updated ALL Plugins one by one
2a. Run all WCML updates
2b. Translated some missing Product Slugs
2c. Created missing Shop pages (in Chinese)
3. Reactivated ALL Plugins one by one

==> The Plugin "WooCommerce - Store Exporter" can't be activated anymore.
I assume this was the issue causing Plugin that destroyed your cart / checkout upon the update.
It produces a warning:
"The plugin generated 2 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin."

The checkout order details are now not anymore missing (see screenshots)
(in EN and Chinese)

Please can you confirm that following the above steps you are able to correctly update?
(Please keep in mind to backup first)

Thank you

January 13, 2015 at 6:24 am #541426

David

Thanks. I will go through the list and let you know the result. Please keep this open until I have had a chance to try this.
Dave

January 13, 2015 at 10:08 am #541546

David

How do I translate the product slugs? I can't find anything about this in your documentation. If I go to string translation, I see product category slugs and product tag slugs But I don't see product slugs.

January 13, 2015 at 12:26 pm #541666

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch ) Italian (Italiano )

Hello David

In WPML > Translation Management > Multilingual Content > Custom posts you've had some warnings regarding "Products"

I translated them as part of the process.
Though I don't suspect it to be the main issue here.

I suspect the mentioned plugin.

Thank you

January 14, 2015 at 10:07 am #542223

David

I am still having some trouble. I removed the plugin from both the live site and the staging site. There was some improvement in the live site, which is still running the older version of WooCommerce. It now works in all 3 browsers on my computer, but it still doesn't work in Chrome on my iPad.

I then updated the live site with the plugin removed, and I have the same problems I had before. I think it is important to note that if I deactivate WPML, regardless of whether I am using the old or new version of Woocommerce, the cart page show up in Chinese instead of English. I am not talking about the widgets on the side, but the url and the things called by the Woocommerce shortcode. Why are things getting translated with the plugin deactivated? The checkout page is calling the correct page, but the order information and shipping information is missing. It seems that the information is not getting passed from cart to checkout.

I should also note that after updating, it appeared to work with wpml activated and using the 2015 theme. While this might indicate that I should change my theme, when I deactivate WPML I get the same behavior as above, with the cart in Chinese and the checkout without order total or shipping info. This makes me think that using a new theme might give me a false sense of security. It might appear that the site is working, but it might not work in some environments. (on Apples using a particular version of a browser for example). Our sales are down 30 to 40% this month and I suspect it is partly due to people not being able to order in certain configurations/ browsers.

The staging site seems to work no matter what, so that doesn't seem to be a reliable indicator.

Can you please try disabling WPML and see if you get the same result on the site you duplicated?

Regarding the other steps you mentioned:
translating product slugs-- I entered the translation for "products" under custom posts and the warning went away. My products show up with the Chinese from the title in the URL, so I think the slugs are getting translated. If I have to translate each product slug one at a time, I still don't know how to do that. I realize there are some untranslated tags and attributes, but most of these are not actually used anyway.

Creating translations of missing pages-- Under Multilingual setup, I have a warning saying that the shop pages are missing in Chinese. However, as far as I know all the pages have been translated. A translation for each page shows up in the pages menu. And when I click the "create pages" link, nothing happens.

I would love to hear any further advice. However, please try disabling WPML and see if you get the Chinese pages as I do.

Thanks, (and sorry for the rambling post.)
Dave

Ps. I should mention that when I say the shipping and order total information are missing, I should mention that they show up for a second. Then they fade and there is a little running symbol, like a translation is being called or something is happening, and then they disappear.

January 15, 2015 at 2:14 pm #543183

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch ) Italian (Italiano )

Hello David

Please, do you have chance to try it with this exact steps:

1. Disabled ALL Plugins but WPML, WooCommerce + WooCommerce Multilingual
2. Updated ALL Plugins one by one
2a. Run all WCML updates
2b. Translated some missing Product Slugs
2c. Created missing Shop pages (in Chinese)
3. Reactivated ALL Plugins one by one

Some plugins might interfere with the update.
Please follow above steps.
They worked for me.
The only difference is the PHP version (mine is the last available), and that it is a a local install.

I also will answer her e a quetison form your DOC:
"It also seems that product names are sometimes being passed to us in the emails in Chinese, even though the customer ordered in English. It shows up in the order panel in English, but the email shows the order in Chinese. "
==> This is aBUG and will be fixed in the next WCML release. We apologize any inconvenience here.

I have also tried to deactivate WC Multilingual on my localhost and unless one title, all content is shown in English.

I assume we have some differences created either by the different PHP versions or the different update processes.

I also tired ot deactivate WPML, with the rest ON, and I have a few more tittles with Chinese content, but only a few.
This might be solved by going through the WPML > Support > Troubleshoot steps.
(If the content isn't actually entered in original product already in Chinese)

Also I did not experience this issue:
"Creating translations of missing pages-- Under Multilingual setup, I have a warning saying that the shop pages are missing in Chinese. However, as far as I know all the pages have been translated. A translation for each page shows up in the pages menu. And when I click the "create pages" link, nothing happens."
== might also be due to the different update processes

If you have a chance to (with backup) rollback on your live site, I could try to troubleshoot it directly there, as with the current situation, we get different results.

Please can you try the exact above steps, and if the issues persists, I would need permission to check this on your live site.

==> What I have also not noted initially, because I used a standard wp-config.php file, is that you have a lot of non-standard entries/codes in your wp-config.php file.
In example caching, redirections and others.

It can (does not mean this IS the issue) create trouble.

Please let me know on how you would like to proceed.

Thank you

January 19, 2015 at 8:09 am #544684

David

Hi Beda,

I have figured it out. For some reason, when I deactivate WPML, the translated pages show up in the selection of native language pages, and in fact the selection on the WooCommerce pages changes to the translated versions instead of the default language pages. I am not sure if that is unique to my site or if it is a bug with either WPML or WooCommerce. Either way, it is easy to work around as long as I don't deactivate WPML, or if I do, I just have to re-designate the WooCommerce pages to the default language. That explains why the site wasn't working with WPML disabled.

I also found some code in my child theme that was causing it to break with WPML activated. I am not sure why it wasn't doing it on the testing site. But when I removed the code, it works fine.

For your reference (or others reading this forum) I have included the script below in case you run into this problem again. I found it online and it has been running on my site for more than a year without any problem. It is supposed to prevent a call to check the version of scripts every time the page loads
Code starts here:
function _remove_script_version( $src ){
$parts = explode( '?', $src );
return $parts[0];
}
add_filter( 'script_loader_src', '_remove_script_version', 15, 1 );
add_filter( 'style_loader_src', '_remove_script_version', 15, 1 );
Code ends here.

Thanks for all your help.
Dave